NetCast SDK v2.4.0

The NetCast SDK is a development tool that provides developers with LG IDE for web application development, the emulator for testing Web/Flash application, and related documents. Developers can create contents for NetCast TV easily using this SDK.

Linux

Mac

Windows

Hardware Requirements

  • Processor: Pentium 4.2.0 GHz or higher

  • RAM: 1 GB or higher

  • OS (32bit/64bit):

    • Windows XP Service Pack 2 or higher, Windows 7
      (In 64-bit Windows, some PCs may have Emulator performance down problem.)

    • Ubuntu 10.04 / 12.04, Ubuntu Mint 13 Maya

    • Mac OS X 10.6 Snow leopard, 10.7 Lion, 10.8 Mountain Lion, 10.9 Mavericks and 10.10 Yosemite

  • Screen resolution: 1280 x 1024 or higher

  • Video memory: 256 MB or higher

Software Requirements

  • Oracle VirtualBox: Version 4.1.18 or higher (for LG Smart TV Emulator 2012)

  • Safari: Version 5.1.7 or higher (for LG IDE)

  • Microsoft DirectX End-User Runtimes (June 2010) (for video rendering in LG Smart TV Emulator 2011)

  • Eclipse IDE for Java EE Developers: Indigo Service Release 2 (for LG IDE Plugin)

  • Java runtime environment (JRE): Version 1.6.0_29 or 1.6.0_30 (for LG IDE Plugin)

  • Adobe Flash CS: (Flash app development: version 4.0 or higher / AIR app development: version 5.5)

  • Player: Flash app development: Flash player version 10 or higher / AIR app development: AIR version 2.6

For more information, refer to the "Release Notes" and "Installation Guide" from Document.

Navigation