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Testing App on Emulator 
 
This section includes the following documents for testing application on emulator. 
 
Running and Debugging on Emulator from LG IDE 

This document describes how to run and debug the application on LG Smart TV Emulator from LG IDE. 
 

Using LG Smart TV Emulator 2013 

This document introduces how LG Smart TV Emulator 2013 works. This section covers the overview and user 
interface of the emulator, and how to use it. 
 

Using LG Smart TV Emulator 2012 

This document introduces how LG Smart TV Emulator 2012 works. This section covers the overview and user 
interface of the emulator, and how to use it. 
 
Using LG Smart TV Emulator 2011 

This document introduces how LG Smart TV Emulator 2011 works. This section covers the overview and user 
interface of the emulator, and how to use it. 
 
List of Supported Codecs and Containers 

This document provides the table specifies all the supported codecs and containers by emulator and real TV in more 
detail. 
 
Using Resource Monitor 

This document explains how to use LG Resource Monitor for monitoring the resource usage status of emulator. 
 
Troubleshooting 

This section describes solutions for LG Smart TV Emulator. 
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Running and Debugging on Emulator from 
LG IDE 

This section describes how to run and debug the application on LG Smart TV Emulator. 
 
 Debugging on LG Smart TV Emulator 2013 
 Debugging on LG Smart TV Emulator 2012 
 Debugging on LG Smart TV Emulator 2011 
 Running on LG Smart TV Emulator 

 
 

Debugging on LG Smart TV Emulator 2013 

1. In IDE, click [Run Emulator > Debug Configuration] menu or toolbar icon . Then, the Debug Configuration 

window will be opened. 
 
2. Select Target, Start Page, and HTTP Web Server Port Number. Then, click [Apply]. 

 

Note 

- If you change the server port number, LG IDE will be restarted. As ‘8787’ is preoccupied, do not use it. 
- The IP address of the local server, your current PC, is displayed in the ‘Real TV’ field. 

 

 
 
3. Click [Debug]. Then, LG IDE starts to begin the [Remote Debug] mode. Or, click [Close] to begin by [Run 
Emulator > Debug] menu later. 

 
4. Then, the following popup appears. 
 

 
 
5. Finally, [Remote Debug] mode is opened and developer can debug the application on LG Smart TV Emulator 2013 
using ‘Web Inspector’. 
 



 

 6 

Note 

If you change the mode from remote debug perspective to other perspective, the web inspector is automatically 
closed. To open the closed web inspector again, you should run the debugger by clicking [Run Emulator > Debug 

Configuration] menu or toolbar icon . 

For details to change the mode, refer to “Changing the Perspective” from Developing > Using SDK > Utilities.  

 
Refer to the following URL to learn about ‘Web Inspector’: https://developers.google.com/chrome-developer-
tools/docs/overview 

 

 
 

Note 

The Safari browser should be installed on your PC to use Web Inspector in LG IDE. 

 

Debugging on LG Smart TV Emulator 2012 

1. In IDE, click [Run Emulator > Debug Configuration] menu or toolbar icon . Then, the Debug Configuration 

window will be opened. 
 
2. Select Target, Start Page, and HTTP Web Server Port Number. Then, click [Apply]. 

 

Note 

- If you change the server port number, LG IDE will be restarted. As ‘8787’ is preoccupied, do not use it. 
- The IP address of the local server, your current PC, is displayed in the ‘Real TV’ field. 

 

https://developers.google.com/chrome-developer-tools/docs/overview
https://developers.google.com/chrome-developer-tools/docs/overview
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3. Click [Debug]. Then, LG IDE starts to begin the [Remote Debug] mode. Or, click [Close] to begin by [Run 
Emulator > Debug] menu later. 

 
4. Then, the following popup appears. 
 

 
 
5. Finally, [Remote Debug] mode is opened and developer can debug the application on LG Smart TV Emulator 2012 
using ‘Web Inspector’. 
 

Note 

If you change the mode from remote debug perspective to other perspective, the web inspector is automatically 
closed. To open the closed web inspector again, you should run the debugger by clicking [Run Emulator > Debug 

Configuration] menu or toolbar icon . 

For details to change the mode, refer to ‘Changing the Perspective’ from Developing > Using SDK > Utilities.  

 
Refer to the following URL to learn about ‘Web Inspector’: https://developers.google.com/chrome-developer-
tools/docs/overview 

 

https://developers.google.com/chrome-developer-tools/docs/overview
https://developers.google.com/chrome-developer-tools/docs/overview
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Note 

The Safari browser should have been installed to your PC to use Web Inspector in LG IDE. 

 

Debugging on LG Smart TV Emulator 2011 

1. In IDE, click [Run Emulator > Debug Configuration] menu or toolbar icon . Then, the Debug Configuration 

window will be opened. 
 
2. Select Target, Start Page, and HTTP Web Server Port Number. Then, click [Apply]. 

 

Note 

- If you change the server port number, LG IDE will be restarted. As ‘8787’ is preoccupied, do not use it. 
- The IP address of the local server, your current PC, is displayed in the ‘Real TV’ field. 
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3. Click [Debug]. Then, LG IDE starts to begin the [Local Debug] mode. Or, click [Close] to begin by [Run Emulator 
> Debug] menu later. 

 
4. Then, the following popup appears. 
 

 
 
5. Finally, [Local Debug] mode is opened and developer can debug the application on LG Smart TV Emulator 2011. 
 
 

Inserting the Debugging Code in the Application 

1. Open the JavaScript file in LG IDE. 
 
2. Write your console log message in .js file for debugging. 
 

 
 
3. Toggle the breakpoint in .js file where you want to debug.  
To toggle breakpoints in JavaScript file, click [Toggle Breakpoint] from the right-click menu on the left grey vertical 

line where you want to insert a breakpoint. 
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Local Debug Perspective 

In [Local Debug] mode, Local Debug Perspective has views as below. 
 
 Breakpoint View 
 Variable View 
 Log View 
 Project Files View 
 Debug Scripts 
 JavaScript Expression View 
 Debug Scripts View 
 
If a view is not shown in the screen, go to [Windows > Show View] and select the view to use. 

 

 
 

[Table] Local perspective views 

Category Description 

Breakpoint 
View 

It keeps track of all breakpoints presented in JavaScript file. You can skip, enable, and disable  
the breakpoints by selecting the check box. 
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Category Description 

 
 

Variable View 

It displays all variables presented in JavaScript file. 
 

 
 

Log View 

It displays the log content. You can remove and export log message to selected location. 
 

 
 
When you save the log message for the first time, you will be asked to select a location where to 
store the log file. Afterwards, when you use this option, it will be directly stored in the previously 

selected location. To save the log message to a file, click  (Export Log) button. 
 

Project Files 
View 

It displays all the web application files for debugging. 
 

 
 

Debug View 
It keeps track of all thread running with debug server. We can use resume, suspend, and stop 
methods to take control of these threads. 
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Category Description 

 
 

JavaScript 
Expression 
View 

This view is used for changing variable values and give some JavaScript expressions during 
debugging. You can add and remove watch expressions. 
 

 
 

 
 

 
 
This expression is changing the text field value of variable val1 to 15. Therefore, output in LG 
Emulator will come with this updated value. 
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Category Description 

 
 

Debug Scripts 
View 

This view shows the file list (html, javascript) for debugging. If you double-click on a list item, the 
file is opened on the source editor. 
 

 
 
 

Running on LG Smart TV Emulator 

1. In IDE, click [Run Emulator > Run Configuration] menu or toolbar icon . Then, the Run Configuration 

window will be opened. 
 
2. Select Target, Start Page, and HTTP Web Server Port Number. Then, click  [Apply]. 

 

Note 

- If you change the server port number, LG IDE will be restarted. As ‘8787’ is preoccupied, do not use it. 
- The IP address of the local server, your current PC, is displayed in the ‘Real TV’ field. 
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3. If you click [Run], the project starts to run on the target. You can also run the project by clicking on [Run Emulator 
> Run] menu later. 

 
4. Then, ‘the following popup appears. 
 

 
 

 
 
4. Finally, the application is launched on the emulator. 
 

Caution 

If the application is not launched on the emulator properly, check if the port ‘8080’ is preoccupied in external server. If 
so, change the default port in [Run Emulator > Run Configuration] menu or release the port of the external server. 

 
If LG Smart TV SDK V2.2 or higher version is installed on your PC, you should not use the eclipse plugin provided 
by SDK V2.1. In this case, the error may occur during running the emulator. Therefore, use the LG IDE provided by 
SDK V2.2 or higher version. 
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Using LG Smart TV Emulator 2013 

This section introduces how LG Smart TV Emulator 2013 works. This section covers the overview and user interface 
(UI) of the emulator, and how to use it. 
 

• Overview of the LG Smart TV Emulator 2013 

• Getting Started 

• Main Functions of Emulator 2013 

 

Overview of the LG Smart TV Emulator 2013 

LG Smart TV Emulator 2013 is a tool that provides developers with the same environment as the target DTV on their 
PC. Content developers can test DTV Web-based contents on their PC using this emulator. The emulator emulates 
the actual hardware, library, and graphics of DTV, which are compatible with the PC environment. Content 
developers can minimize the development period using this emulator without the target DTV. 
 
LG Smart TV Emulator 2013 has the following features: 
 
 Playing Web content for TV with LG Browser emulation 
 IR Remote emulation 
 
LG Smart TV SDK provides following features: 
 LG Smart TV Emulator 2011: Emulator for LG Smart TV released in 2011 
 LG Smart TV Emulator 2012: Emulator for LG Smart TV released in 2012 
 LG Smart TV Emulator 2013: Emulator for LG Smart TV released in 2013 (This emulator is based on Ubuntu 10.04) 
 

Caution  

LG Smart TV Emulator 2013 has some differences from the LG Browser on the target DTV. Developers should 
keep in mind these differences when they test applications on the emulator. For detailed information, see Section 
Differences from the TV.  

 
Specifications and Differences from the TV are listed in the following sections. 

• Specifications 

• Differences from the TV 

 

Specifications 

LG Smart TV Emulator 2013 uses the same Browser engine as the one in the target DTV. 
For the LG Browser engine specifications, refer to the “Web Engine” in Developing > Developing Web App > App 
Development Guide > Specifications section in this Library. 

 

Differences from the TV 

LG Smart TV Emulator 2013 has some differences from LG Browser on the target DTV. Developers should keep in 
mind these differences when they test applications on the emulator. 
The table below lists LG Smart TV features that work differently on the emulator and on DTV.  
 

[Table] Differences between Emulator and DTV Target 

Feature 
LG Smart TV Emulator 

2013 
DTV 2013 

Performance  
Depending on the PC where the 
emulator is running. 

Depending on the target DTV 

Resource size 

Depending on the memory of the PC. 
Note that the memory of the PC is 
much greater than the one on the 
target DTV board. 

Depending on the memory of the target 
DTV 

Image decoder prebuilt libjpeg7-win32 patched JPEGsrc.v6b 

DRM Not supported 
WM DRM-PD Version 10 is not supported. 
PlayReady and WideVine DRM are 
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Feature 
LG Smart TV Emulator 

2013 
DTV 2013 

supported. 

Magic Remote 
Supported limitedly  
- Acceleration sensor is not supported. 

Supported 

Media player Refer to the List of Supported Codecs and Containers. 

Flash Not supported Supported 

HTML5 Supported Supported 

PLEX Not supported Supported 

TP Streaming Not supported Supported 

USB Emulation Not supported Supported 

DTV General Not supported Supported 

EMF Not supported Supported 

DLNA Not supported Supported 

DVR Ready Not supported Supported 

3DTV Not supported Supported 

C Native Not supported Supported 

LG Apps Not supported Supported 

My Apps Not supported Supported 

SDP Client Not supported Supported 

 

Note 

Between the DTV and emulator, there may be performance difference depending on CPU speed and video memory 
of the PC that developers use (e.g. graphic rendering speed and quality, video streaming speed). 

 

Getting Started 

This chapter covers the user interface of LG Smart TV Emulator 2013 and how to navigate in the emulator. Also, 
menu descriptions on emulator are provided. 
 
This section includes the following sections. 
 Starting and Exiting the Emulator 
 User Interface of the Emulator 
 Navigation in Emulator 
 Menu Description 

 

Starting and Exiting the Emulator 

Select [Start > Program > LG Smart TV SDK > LG Smart TV Emulator 2013] to launch the emulator after installing 

it. Then, the virtual machine will launch the emulator. When the emulator starts running, the TV and IR Remote 
emulator run by default. 
 

Caution  

Be sure that VirtualBox should be installed on your PC first before installing LG Smart TV SDK in order to operate 
LG Smart TV Emulator 2013 normally. 
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[Figure] Emulator Execution 

 

To exit the emulator, press the  button on IR Remote emulator or select [Exit] in the emulator menu. Then, the 
following pop-up window appears. Press the [Yes] button to exit the emulator. 

 

 
 

Note  

You can also exit the emulator by pressing the  button on the top right. 

 
 

User Interface of the Emulator 

LG Smart TV Emulator 2013 basically consists of the main window and IR Remote emulator. All of navigation of 
emulator is done by the remote control and PC mouse. (see Section Navigation in Emulator) 
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[Figure] User Interface of LG Smart TV Emulator 2013 

 
The following describes each part of the emulator. 
 

① Main window 

The main window that displays the operation of the emulator. The emulator has the same resolution as the TV screen. 
You can resize the main window. 
 

② Emulator menu 

Click the  button on the top right of the IR Remote to open the emulator menu. (see Emulator Menu) 

 

③ IR Remote emulator 

Emulates the TV IR Remote. (see IR Remote Menu) 

 

④ Minimize and Exit 

Press the  and  button to minimize and maximize the emulator window; press the  button to exit the 
emulator. 
 

Navigation in Emulator 

In order to navigate, LG Smart TV Emulator 2013 uses a remote control as you do with the target DTV, but it does not 
support a keyboard. Users of the TV-based web contents may not have mouse and keyboard. Therefore, you might 
need to estimate usability of the content without mouse or keyboard – with IR Remote emulator. 
 
When you want to emulate navigation using the Magic Remote, you need to use your PC mouse. Move the cursor 
using your mouse on the emulator screen.  
 

Note  

To learn about IR Remote menu, see IR Remote Menu. 

 

Menu Description 

This chapter describes the functions of the emulator menu and remote control menu provided by LG Smart TV 
Emulator 2013. 

Emulator Menu 

To display the emulator menu, click  on the top right of the emulator remote control. Run the basic functions 
of the emulator and set the options using this menu. 
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[Figure] Emulator Menu of LG Smart TV Emulator 2013 

The following table describes on the emulator menu in LG Smart TV Emulator 2013. 
 

[Table] Emulator Menu Description 

Menu Description 

Proxy Configuration 
If you use a proxy, enter the proxy server address and port number. 
See Proxy Configuration. 

Run Browser 
Enters the URL address to access in the browser. 
See Browser Emulation. 

Terminate Running App Kills the currently running application. 

Show Log Runs LG Resource Monitor Tool. See Show Log. 

Overscan Area On 
In Blu-ray Player, overscan area of the screen should be considered. This area must 
be blank in your application.  
See Overscan Area. 

Add Browser Font Installs an additional browser font. See Add Browser Font. 

Take Screenshot Takes a screenshot of the main window. See Take Screenshot. 

Test Media File Opens a media file at main window. See Test Media File. 

Send Voice Input Sends a word instead of the voice for the voice test. See Send Voice Input. 

About Version of the LG Smart TV Emulator 

Exit Exits the emulator. 

 

IR Remote Menu 

To emulate the TV IR Remote and its functions, LG Smart TV Emulator 2013 provides the IR Remote emulator. The 
IR Remote emulator is displayed in a separate window, and you can drag it to the desired position on your desktop. 
 

Note  

If you cannot see the remote control when using LG Smart TV Emulator 2013, click on the tray icon or the emulator 
tab on launch bar to launch it. 
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[Figure] IR Remote of LG Smart TV Emulator 2013 

 
The following table describes the buttons on the remote control. 
 

[Table] IR Remote Menu 

Button Description Disabled/Enabled 

① [POWER]: Turns the emulator off. Enabled 

② 
 [RATIO]: Selects your desired Aspect Ratio of picture. 
 [INPUT]: External input mode rotates in regular sequence. 
 [TV/RAD]: Selects Radio, TV and DTV channel. 

Disabled, 
[TV/RAD] button is 
enabled 

③ 

 [0~9]: Selects channel numbers. 
 [LIST]: Displays the channel table. Also, sets the TV mode and the 
desired favorite channels list. 
 [Q.VIEW]: Displays a list of the most recently viewed channels. 

Enabled, 
[Q.VIEW] button is 
disabled 

④ 

 [FAV]: Changes the channel alternating the registered favorite 
channels. 
 [3D]: Converts into the 3D mode. 
 [MUTE]: Switches the sound on/off. 

 [VOL +,−]: Adjusts the volume. 

Enabled 
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Button Description Disabled/Enabled 

 [PAGE +,−]: Changes the channel. 

⑤ 
 [SETTINGS]: Opens the settings options. 
 [Home]: Enters into the Home Dashboard page. 
 [MY APPS]: Enters into the My Apps page. 

Disabled 
[SETTINGS] button 
is enabled 

⑥ 

Navigation keys for the menu. Press [OK] to choose the menu. 
 [BACK]: Returns to the previous menu or exit from current menu. 
 [GUIDE]:Shows the channel schedule. 
 [EXIT]: Returns to the previous menu or exit from current menu. 

Enabled 

⑦ 
[RED,GREEN,YELLOW,BLUE]: If necessary, DTV content explains 
the color icons for a specific feature. 

Enabled 

⑧ 
 [TEXT], [T.OPT]: These buttons are used for teletext. 
 [Q.MENU]: Opens the list of Quick Menu options. 

Disabled 

⑨ 

 [STOP]: Stops DivX. 
 [PLAY]: Plays DivX. 
 [PAUSE]: Pauses DivX. 
 [REWIND]: Rewinds DivX. 
 [FASTFORWARD]: FastForwards DivX. 
 [REC]: Records DivX. 
 [ENERGY SAVING]: Sets the energy saving mode. 
 [INFO]: Channel Information. 

 [ⓢIMPLELINK]: Links to the TV, DISC, VCR1, HDD Recorder and 

Speaker. 

Disabled, 
[INFO] button is 
enabled 

⑩ : Emulator Menu Button Enabled 

 

Note  

[Menu] button is enabled after finishing Emulator booting. 

 

Main Functions of Emulator 2013 

This chapter introduces the main functions of the emulator such as Browser emulation. It also describes on how to 
use basic DTV emulation functions. 
 
Main Function of Emulator 2013 are as follows: 
 Proxy Configuration 
 Browser Emulation 
 Show Log 
 Overscan Area 
 Add Browser Font 
 Take Screenshot 
 Test Media File 
 Send Voice Input 

 

Proxy Configuration 

LG Emulator supports proxy configuration.  
 
1. Press [Proxy Configuration] in the emulator menu after starting the emulator. 

 
2. If you use a proxy, enter the proxy server address and port number. 
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If you do not use proxy, select [Don’t Use Proxy]. 
 
3. Click [OK] button to save the configuration. 

 

Browser Emulation 

LG Browser is a web browser for digital TV sets. LG Smart TV Emulator 2013 can open URLs and local URLs on PC 
for testing web content. Since the emulator uses the same source code as the LG Browser running on the DTV, it 
reproduces its behaviour quite accurately. Because of the differences between PC and TV platforms, the emulator 
has differences from the TV. (See Differences from the TV)  

 
     Opening URLs: Testing a server-based URL 
     Opening Local URLs: Testing a local URL 
 

Opening URL 

Follow the next steps to open a URL. 
 
1. Press [Run Browser] in the emulator menu. The following window appears in which you can enter a URL. Enter 
the URL and click [GO] to open the URL. To delete the URL from history, select URL and click the [Delete From 
History]. 

 

 
 
2. Enter the URL address you want to access and press the [GO] button. For example, enter http://www.lg.com. 

 
3. Then, you can view the website of the URL in the emulator's browser as shown below. 
 

 
 

Note  

To delete the URL from history, select URL and click the [Delete From History]. 

 

Opening Local URL 

LG Smart TV Emulator 2013 supports local URL. This function is not supported on the LG Browser running on the 
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DTV. Developers can test the developed application stored in their PC. 
 
1. Press [Run Browser] in the emulator menu. The following window appears in which you can enter a URL. 

 

 
 
A. If you have created a project and started the web server in LG IDE, you can run the web application in localhost. 
Enter http://localhost:<port number>/<project name>/<html file name> or http://127.0.0.1:<port 
number>/<project name>/<html file name> in the window. The <port number> is the value set in Run Configuration 

window of LG IDE. 
 
This is the example: http://localhost:8080/myproject/index.html 
 
B. If you did not start the web server on your PC, put your application files under C:\Documents and 
Settings\user\LG_Smart_TV_SDK\FlashWorkspace. Then, enter file:///C:\Documents and 
Settings\user\LG_Smart_TV_SDK\FlashWorkspace\<html file name> in the window. 
 
2. Press [GO] to open the web application stored on your PC. 

 
3. Then, you can view the page of the local URL in the emulator's browser. 
 

Note  

The user folder for LG Smart TV SDK is different from each user environment. 

 

Show Log 

You can run the Resource Monitor by the show log menu. For more information about resource monitor, refer to 
Using LG Resource Monitor. 
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Overscan Area 

In Blu-ray Player, overscan area of the screen should be considered. This area must be blank in your application.  
 
Press [Overscan Area On] in the emulator menu. 

 

 
 
Then, the following window appears. You can check the overscan area. 
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For more information, refer to the “LG Smart TV and Media Product UI Guideline” in [DISCOVER > Legacy 
Platform (NetCast) > Technical Notes] in this website. 

 

Add Browser Font 

In LG Smart TV Emulator 2013, you can add a new font to the emulator.  
If you are a CP (partner) member, you can test the font on the emulator before packaging your application for real TV. 
 
1. Press [Add Browser Font] in the emulator menu. Then, the following window appears. Select the font file to install. 

 

 
 

2. Press the [install] button after entering the file path of the font file stored on your PC.  

 
3. Then, you can use the installed font in emulator. 
 

Caution 

When you restart the emulator, previous applied font cannot use anymore on the emulator. 

 

Take Screenshot 

In LG Smart TV Emulator 2013, you can save a image of current screen into the user specified folder.  
 
1. Press [Take Screenshot] in the emulator menu. Then, the following window appears. The file name is created 

automatically. You can change file name before pressing the take button. 
 

 
 
2. Press the [Take] button. 

 
3. Then, you can get image files under C:\Documents and Settings\user\LG_Smart_TV_SDK\ScreenShot. 
 

Note  

The user folder for LG Smart TV SDK is different from each user environment. 

http://webostv.developer.lge.com/discover/netcast/technical-notes/
http://webostv.developer.lge.com/discover/netcast/technical-notes/
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Test Media File 

You can test media files whether it is playable on the LG Smart TV. 
 

Note  

Codec Coverage of the LG Smart TV Emulator can be differnet from the target. (See Section List of Supported 
Codecs and Containers.) 

 
1. Press [Test Media File] in the emulator menu. Then, the following window appears. Select the media file to play. 

 

 
 
2. Press the [Run] button after entering the file path of the media file stored on your PC.  

 
3. Then, the emulator plays the selected media file as following. 
 

Caution 

Before testing media file, you must put the media file under C:\Documents and 
Settings\user\LG_Smart_TV_SDK\FlashWorkspace. 

 
 

 
 

Send Voice Input 

Send Voice Input is also available at LG Smart TV Emulator, just like a same style in Magic Remote. 
 
1. Press [voice input] button in the application. Then, the following window appears in emulator.  

 

Note  

Voice Input button is only available when developers have implemented it in the application. 
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2. Press [Send Voice Input] in the emulator menu. 

 

 
 
3. Press [Send] button after entering word in the Voice textbox. 

 

Note  

To delete a word from history, select the word and click the [Delete From History]. 

 
4. The emulator sends inputted word to the application according to input mode. 
 
Dictation Mode 

Dictation Mode sends inputted word from send voice input to the application directly without the similar list.  
 
Keyword Mode 

Keyword Mode shows the similar list to choose similar word as inputted word from send voice input. When user 
select a word, emulator sends that to the application.  
 

Note  

The Similar List shows a maximum of three similar word. 
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Using LG Smart TV Emulator 2012 

This section introduces how LG Smart TV Emulator 2012 works. This section covers the overview and user interface 
(UI) of the emulator, and how to use it. 
 
 Overview of the LG Smart TV Emulator 2012 
 Getting Started 
 Main Functions of Emulator 2012 

 

Overview of the LG Smart TV Emulator 2012 

LG Smart TV Emulator 2012 is a tool that provides developers with the same environment as the target DTV on their 
PC. Content developers can test DTV Web-based and Flash contents on their PC using this emulator. The emulator 
emulates the actual hardware, library, and graphics of DTV, which are compatible with the PC environment. Content 
developers can minimize the development period using this emulator without the target DTV. 
 
LG Smart TV Emulator 2012 has the following features: 
 
 Playing Web content for TV with LG Browser emulation 
 Playing Flash content for TV with LG Flash emulation 
 Playing Flash content for TV with LG AIR emulation 
 IR Remote emulation 
 
LG Smart TV SDK provides following features: 
 LG Smart TV Emulator 2011: Emulator for LG Smart TV released in 2011 
 LG Smart TV Emulator 2012: Emulator for LG Smart TV released in 2012 (This emulator is based on Ubuntu 10.04) 
 LG Smart TV Emulator 2013: Emulator for LG Smart TV released in 2013 
 

Caution  

LG Smart TV Emulator 2012 has some differences from the LG Browser and Flash player on the target DTV. 
Developers should keep in mind these differences when they test applications on the emulator. For detailed 
information, see Section Differences from the TV.  

 
Specifications and Differences from the TV are listed in the following sections. 
 Specifications 
 Differences from the TV 

 

Specifications 

LG Smart TV Emulator 2012 uses the same Browser and Flash engine as the one in the target DTV. 
For the LG Browser engine specifications, refer to the “Web Engine” in Developing > Developing Web App > App 
Development Guide > Specifications section in this Library. 

 
The table below shows the LG Flash player specifications. 
 

[Table] LG Flash Player Specifications 

Type Item LG Smart TV Emulator 2012 

SWF 
Version Flash Player 10.1, AIR 3.0 

ActionScript AS 3.0 

Graphics 
Resolution 1280 x 720 

Type of images loadable during runtime PNG , JPEG 

Sound 
Format MP3, AAC, PCM (Event sound only) 

Sample rate 16 kHz, 32 kHz, 44.1 kHz 

Flash Video 
SW Codec  

On2 , Sorenson - Low quality video (because of 
SW Codec limitation) 

HW Codec  H.264 (with AAC audio only) 
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Type Item LG Smart TV Emulator 2012 

- Recommended video resolution Up to FHD (1080 p) 

- Recommended audio sample rate 44.1 kHz 

Streaming Protocol Not Supported 

Security 
NetCast 3.0 does not support RTMP-e and 
FlashAccess3.0. 

 

Differences from the TV 

LG Smart TV Emulator 2012 has some differences from LG Browser and Flash player on the target DTV. Developers 
should keep in mind these differences when they test applications on the emulator. 
The table below lists LG Smart TV features that work differently on the emulator and on DTV.  
 

[Table] Differences between Emulator and DTV Target 

Feature 
LG Smart TV Emulator 

2012 
DTV 2012 

Performance  
Depending on the PC where the 
emulator is running. 

Depending on the target DTV 

Resource size 

Depending on the memory of the PC. 
Note that the memory of the PC is 
much greater than the one on the 
target DTV board. 

Depending on the memory of the target 
DTV 

Image decoder prebuilt libjpeg7-win32 patched JPEGsrc. v6b 

DRM Not supported 

WM DRM-PD Version 10, Playeady and  
WideVine DRM are supported. 
Adobe Access 3.0 DRM is supported only 
in NetCast 3.0 

Magic Remote 
Supported limitedly  
- Acceleration sensor is not supported. 

Supported 

Media player Refer to the List of Supported Codecs and Containers. 

Flash Supported Supported 

HTML5 Supported Supported 

PLEX Supported Supported 

TP Streaming Not supported Supported 

USB Emulation Not supported Supported 

DTV General Not supported Supported 

EMF Not supported Supported 

DLNA Not supported Supported 

DVR Ready Not supported Supported 

3DTV Not supported Supported 

C Native Not supported Supported 

LG Apps Not supported Supported 

My Apps Not supported Supported 

SDP Client Not supported Supported 

 

Note  

Between the DTV and emulator, there may be performance difference depending on CPU speed and video memory 
of the PC that developers use (e.g. graphic rendering speed and quality, video streaming speed). 
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Getting Started 

This chapter covers the user interface of LG Smart TV Emulator 2012 and how to navigate in the emulator. Also, 
menu descriptions on emulator are provided. 
 
This section includes the following sections. 
 Starting and Exiting the Emulator 
 User Interface of the Emulator 
 Navigation in Emulator 
 Menu Description 

 

Starting and Exiting the Emulator 

Select [Start > Program > LG Smart TV SDK > LG Smart TV Emulator 2012] to launch the emulator after installing 

it. Then, the virtual machine will launch the emulator. When the emulator starts running, the TV and IR Remote 
emulator run by default. 
 

Caution  

Be sure that VirtualBox should be installed on your PC first before installing LG Smart TV SDK in order to operate 
LG Smart TV Emulator 2012 normally. 

 

 

[Figure] Emulator Execution 

 

To exit the emulator, press the  button on IR Remote emulator or select [Exit] in the emulator menu. Then, the 
following pop-up window appears. Press the [Yes] button to exit the emulator. 

 

 
 

Note  

You can also exit the emulator by pressing the  button on the top right 
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User Interface of the Emulator 

LG Smart TV Emulator 2012 basically consists of the main window and IR Remote emulator. All of navigation of 
emulator is done by the remote control and PC mouse. (see Section Navigation in Emulator) 

 

 

 [Figure] User Interface of LG Smart TV Emulator 2012 

 
The following describes each part of the emulator. 
 

① Main window 

The main window that displays the operation of the emulator. The emulator has the same resolution as the TV screen. 
You can resize the main window. 
 

② Emulator menu 

Click the  button on the top right of the IR Remote to open the emulator menu. (see Emulator Menu.) 

 

③ IR Remote emulator 

Emulates the TV IR Remote. (see IR Remote Menu) 

 

④ Minimize and Exit 

Press the  and  button to minimize and maximize the emulator window; press the  button to exit the 
emulator. 
 

Navigation in Emulator 

In order to navigate, LG Smart TV Emulator 2012 uses a remote control as you do with the target DTV, but it does not 
support a keyboard. Users of the TV-based web and Flash contents may not have mouse and keyboard. Therefore, 
you might need to estimate usability of the content without mouse or keyboard – with IR Remote emulator. 
 
When you want to emulate navigation using the Magic Remote, you need to use your PC mouse. Move the cursor 
using your mouse on the emulator screen.  
 

Note  

To learn about IR Remote menu, see IR Remote Menu. 

 

Menu Description 

This chapter describes the functions of the emulator menu and remote control menu provided by LG Smart TV 
Emulator 2012. 

Emulator Menu 



 

 32 

To display the emulator menu, click  on the top right of the emulator remote control. Run the basic functions 
of the emulator and set the options using this menu. 
 

 

[Figure] Emulator Menu of LG Smart TV Emulator 2012 

The following table describes on the emulator menu in LG Smart TV Emulator 2012. 
 

[Table] Emulator Menu Description 

Menu Description 

Proxy Configuration 
If you use a proxy, enter the proxy server address and port number. 
See Proxy Configuration. 

Run Flash / AIR 

Opens a flash file (.SWF) to be played in the Flash player. 
Or, opens a AIR directory to be played in the AIR player. 
See Flash Player Emulation. 
See AIR Player Emulation. 

Run Browser 
Enters the URL address to access in the browser. 
See Browser Emulation. 

Terminate Running App Kills the currently running application. 

Show Log Runs LG Resource Monitor Tool. See Show Log. 

Overscan Area On 
In Blu-ray Player, overscan area of the screen should be considered. This area must 
be blank in your application.  
See Overscan Area. 

Add Browser Font Installs an additional browser font. See Add Browser Font. 

Take Screenshot Takes a screenshot of the main window. See Take Screenshot. 

Test Media File Opens a media file at main window. See Test Media File. 

Send Voice Input Sends a word instead of the voice for the voice test. See Send Voice Input. 

About Version of LG Smart TV Emulator 

Exit Exits the emulator. 

 

IR Remote Menu 

To emulate the TV IR Remote and its functions, LG Smart TV Emulator 2012 provides the IR Remote emulator. The 
IR Remote emulator is displayed in a separate window, and you can drag it to the desired position on your desktop. 
 

Note  

If you cannot see the remote control when using LG Smart TV Emulator 2012, click on the tray icon or the emulator 
tab on launch bar to launch it. 
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[Figure] IR Remote of LG Smart TV Emulator 2012 

 
The following table describes the buttons on the remote control. 
 

[Table] IR Remote Menu 

Button Description Disabled/Enabled 

① [POWER]: Turns the emulator off. Enabled 

② 
 [RATIO]: Selects your desired Aspect Ratio of picture. 
 [INPUT]: External input mode rotates in regular sequence. 
 [TV/RAD]: Selects Radio, TV and DTV channel. 

Disabled, 
[TV/RAD] button is 
enabled 

③ 
 [0~9]: Selects channel numbers. 
 [LIST]: Displays the channel table. 
 [Q.VIEW]: Displays a list of the most recently viewed channels. 

Enabled, 
[Q.VIEW] button is 
disabled 

④ 
 [FAV]: Sets the desired favorite channels list. 
 [3D]: Converts into the 3D mode. 
 [MUTE]: Switches the sound on/off. 

Enabled. 
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Button Description Disabled/Enabled 

 [VOL +,−]: Adjusts the volume. 

 [PAGE +,−]: Changes the channel. 

⑤ 
 [SETTINGS]: Opens the settings options. 
 [Home]: Enters into the Home Dashboard page. 
 [MY APPS]: Enters into the My Apps page. 

Disabled 
[SETTINGS] button 
is enabled 

⑥ 

Navigation keys for the menu. Press [OK] to choose the menu. 
 [BACK]: Returns to the previous menu or exit from current menu. 
 [GUIDE]:Shows channel schedule. 
 [EXIT]: Returns to the previous menu or exit from current menu. 

Enabled 

⑦ 
[RED,GREEN,YELLOW,BLUE]: If necessary, DTV content explains 
the color icons for a specific feature. 

Enabled 

⑧ 
 [TEXT], [T.OPT]: These buttons are used for teletext. 
 [Q.MENU]: Opens the list of Quick Menu options. 

Disabled 

⑨ 

 [STOP]: Stops DivX. 
 [PLAY]: Plays DivX. 
 [PAUSE]: Pauses DivX. 
 [REWIND]: Rewinds DivX. 
 [FASTFORWARD]: FastForwards DivX. 
 [REC]: Records DivX. 
 [ENERGY SAVING]: Sets the energy saving mode. 
 [INFO]: Channel Information. 

 [ⓢIMPLELINK]: Links to the TV, DISC, VCR1, HDD Recorder and 

Speaker. 

Disabled, 
[INFO] button is 
enabled 

⑩ : Emulator Menu Button Enabled 

 

Note  

[Menu] button is enabled after finishing Emulator booting. 

 

Main Functions of Emulator 2012 

This chapter introduces the main functions of the emulator such as Browser and Flash player emulation. It also 
describes on how to use basic DTV emulation functions. 
 
Main Functions of Emulator 2012 are as follows : 
 Proxy Configuration 
 Browser Emulation 
 Flash Player Emulation 
 AIR Player Emulation 
 Show Log 
 Overscan Area 
 Add Browser Font 
 Take Screenshot 
 Test Media File 
 Send Voice Input 

 

Proxy Configuration 

LG Emulator supports proxy configuration.  
 
1. Press [Proxy Configuration] in the emulator menu after starting the emulator. 

 
2. If you use a proxy, enter the proxy server address and port number. 
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If you do not use proxy, select [Don’t use proxy]. 
 
3. Click [OK] button to save the configuration. 

 

Browser Emulation 

LG Browser is a web browser for digital TV sets. LG Smart TV Emulator 2012 can open URLs and local URLs on PC 
for testing web content. Since the emulator uses the same source code as the LG Browser running on the DTV, it 
reproduces its behaviour quite accurately. Because of the differences between PC and TV platforms, the emulator 
has differences from the TV. (See Differences from the TV.)  

 
     Opening URLs: Testing a server-based URL 
     Opening Local URLs: Testing a local URL 
 

Opening URL 

Follow the next steps to open a URL.  
 
1. Press [Run Browser] in the emulator menu. The following window appears in which you can enter a URL. Enter 
the URL and click [GO] to open the URL. To delete the URL from history, select URL and click the [Delete From 
History]. 

 

 
 
2. Enter the URL address you want to access and press the [GO] button. For example, enter http://www.lg.com. 

 
3. Then, you can view the website of the URL in the emulator's browser as shown below. 
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Note  

To delete the URL from history, select URL and click the [Delete From History]. 

 

Opening Local URL 

LG Smart TV Emulator 2012 supports local URL. This function is not supported on the LG Browser running on the 
DTV. Developers can test the developed application stored in their PC. 
 
1. Press [Run Browser] in the emulator menu. The following window appears in which you can enter a URL. 

 

 
 
A. If you have created a project and started the web server in LG IDE, you can run the web application in localhost. 
Enter http://localhost:<port number>/<project name>/<html file name> or http://127.0.0.1:<port 
number>/<project name>/<html file name> in the window. The <port number> is the value set in Run Configuration 

window of LG IDE. 
 
This is the example: http://localhost:8080/myproject/index.html 
 
B. If you did not start the web server on your PC, put your application files under C:\Documents and 
Settings\user\LG_Smart_TV_SDK\FlashWorkspace. Then, enter file:///C:\Documents and 
Settings\user\LG_Smart_TV_SDK\FlashWorkspace\<html file name> in the window. 
 
2. Press [GO] to open the web application stored on your PC. 

 
3. Then, you can view the page of the local URL in the emulator's browser. 
 

Note  

The user folder for LG Smart TV SDK is different from each user environment. 
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Flash Player Emulation 

With the emulator, you can open and execute a Flash file to test it on your PC first. Because of the differences 
between PC and TV platforms, the emulator has Differences from the TV. (See Differences from the TV.) 

 

Note  

Refer to Specifications for LG Flash Player specifications and “Flash Content Design Guide for HDTV” in the 
[DISCOVER > Legacy Platform (NetCast) > Technical Notes] at LG Developer website for Flash content design 

guidelines. 

 

Running Flash Files 

In LG Smart TV Emulator 2012 the SWF file should be placed under the following directory so that the virtual 
machine can find the local file to open on the emulator. 
 

SWF File path in WinXP (default) : C:\Documents and Settings\user\LG_Smart_TV_SDK\FlashWorkspace 

SWF File path in Win7 : C:\Users\user\LG_Smart_TV_SDK\FlashWorkspace 

 
1. In LG Smart TV Emulator 2012, press [Run Flash/AIR] in the emulator menu. 

 
Then, the following window appears, in which you can select a Flash file (.SWF). 
To use default background color with white when executing application, click on the check button. 
 

 
 
If you do not find the SWF file from the correct directory, the following popup message will appear. 
 

 
 

Note  

You can change the workspace directory of your project in Adobe Flash CS. Then, LG Smart TV Emulator 2012 will 
find the local file from the changed directory. Be sure that you must create a shared folder for the workspace 
directory so that the virtual machine can access the file.  

 
2. Press the [Run] button after entering the file path of the Flash file stored on your PC.  

 
3. Then, you can view the opened file in the emulator's Flash player as shown below. 
 

Note 

The user folder for LG Smart TV SDK is different from each user environment. 

 

http://webostv.developer.lge.com/discover/netcast/technical-notes/
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AIR Player Emulation 

LG Smart TV Emulator 2012 can play AIR content. The emulator reads and executes the “META-
INF\AIR\application.xml” file, therefore, the directory of the META-INF folder should be set. Differences may exist 
between real TV and the emulator. 
 
Using the “Step-2. Build and Run Over Emulator” command from LG IDE plug-in menu in Adobe Flash 

Professional CS, you can execute the AIR application (developed with ActionScript 3.0) on emulator. 
 
With the emulator, you can open and execute an AIR file to test it on your PC first. 
 
1. Press [Run Flash/AIR] in the emulator menu. Then, the following window appears, in which you can select a 

directory. Select the .air file to test. To use default background color when executing application, click on the check 
button. 
 

 
 

2. Press the [RUN] button after entering the file path of the AIR file stored on your PC.  

 
3. Then, you can view the opened file in the emulator's AIR as shown below 
 

 
 

Show Log 

You can run the Resource Monitor by the show log menu. For more information about resource monitor, refer to 
Using LG Resource Monitor. 
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Overscan Area 

In Blu-ray Player, overscan area of the screen should be considered. This area must be blank in your application.  
 
Press [Overscan Area On] in the emulator menu. 

 

 
 
Then, the following window appears. You can check the overscan area. 
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For more information, refer to the “LG Smart TV and Media Product UI Guideline” in [DISCOVER > Legacy 
Platform (NetCast) > Technical Notes] in this website. 

 

Add Browser Font 

In LG Smart TV Emulator 2012, you can add a new font to the emulator. 
If you are a CP (partner) member, you can test the font on the emulator before packaging your application for real TV. 
 
1. Press [Add Browser Font] in the emulator menu. Then, the following window appears. Select the font file to install. 

 

 
 

2. Press the [install] button after entering the file path of the font file stored on your PC.  

 
3. Then, you can use the installed font in emulator 
 

Caution 

When you restart the emulator, previous applied font cannot use anymore on the emulator. 

 

Take Screenshot 

In LG Smart TV Emulator 2012, you can save a image of current screen into the user specified folder.  
 
1. Press [Take Screenshot] in the emulator menu. Then, the following window appears. The file name is created 

automatically. You can change file name before pressing the take button. 
 

 
 
2. Press the [Take] button. 

 
3. Then, you can get image files under C:\Documents and Settings\user\LG_Smart_TV_SDK\ScreenShot. 

 

Note  

The user folder for LG Smart TV SDK is different from each user environment. 

http://webostv.developer.lge.com/discover/netcast/technical-notes/
http://webostv.developer.lge.com/discover/netcast/technical-notes/
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Test Media File 

You can test media files whether it is playable on the LG Smart TV.  
 

Note  

Codec Coverage of the LG Smart TV Emulator can be differnet from the target. (See Section List of Supported 
Codecs and Containers.) 

 
1. Press [Test Media File] in the emulator menu. Then, the following window appears. Select the media file to play. 

 

 
 
2. Press the [Run] button after entering the file path of the media file stored on your PC.  

 
3. Then, the emulator plays the selected media file as following. 
 

Caution 

Before testing media file, you must put the media file under C:\Documents and 
Settings\user\LG_Smart_TV_SDK\FlashWorkspace. 

 
 

 
 

Send Voice Input 

Send Voice Input is also available at LG Smart TV Emulator, just like a same style in Magic Remote 
 
1. Press [voice input] button in the application. Then, the following window appears in emulator.  

 

Note  

Voice Input button is only available when developers have implemented it in the application. 
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2. Press [Send Voice Input] in the emulator menu. 

 

 
 
3. Press [Send] button after entering word in the Voice textbox. 

 

Note  

To delete a word from history, select the word and click the [Delete From History]. 

 
4. The emulator sends inputted word to the application according to Input Mode. 
 
Dictation Mode 

Dictation Mode sends inputted word from send voice input to the application directly without the similar list.  
 
Keyword Mode 

Keyword Mode shows the similar list to choose similar word as inputted word from send voice input. When user 
select a word, emulator sends that to the application.  
 

Note  

The Similar List shows a maximum of 3 similar word. 
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Using LG Smart TV Emulator 2011 

This section introduces how LG Smart TV Emulator 2011 works. This section covers the overview and user interface 
(UI) of the emulator, and how to use it. 
 
 Overview of LG Smart TV Emulator 2011 
 Getting Started 
 Main Functions of Emulator 2011 

 

Overview of LG Smart TV Emulator 2011 

LG Smart TV Emulator 2011 is a tool that provides developers with the same environment as the target DTV on their 
PC. Content developers can test DTV Web-based and Flash contents on their PC using this emulator. The emulator 
emulates the actual hardware, library, and graphics of DTV, which are compatible with the PC environment. Content 
developers can minimize the development period using this emulator without the target DTV. 
 
LG Smart TV Emulator 2011 has the following features: 
 
 Playing Web content for TV with LG Browser emulation 
 Playing Flash content for TV with LG Flash emulation 
 IR Remote emulation 
 
LG Smart TV SDK provides following features: 
 LG Smart TV Emulator 2011: Emulator for LG Smart TV released in 2011 
 LG Smart TV Emulator 2012: Emulator for LG Smart TV released in 2012 
 LG Smart TV Emulator 2013: Emulator for LG Smart TV released in 2013 
 

Caution  

LG Smart TV Emulator 2011 has some differences from the LG Browser and Flash player on the target DTV. 
Developers should keep in mind these differences when they test applications on the emulator. For detailed 
information, see Differences from the TV. 

 
Specifications and Differences from the TV are listed in the following sections. 
 Specifications 
 Differences from the TV 

 

Specifications 

LG Smart TV Emulator 2011 uses the same Browser and Flash engine as the one in the target DTV.  
For the LG Browser engine specifications, refer to the “Web Engine” in Developing > Developing Web App > App 
Development Guide > Specifications section in this Library. 

 
The table below shows the LG Flash player specifications. 
 

[Table] LG Flash Player Specifications 

Type Item LG Smart TV Emulator 2011 

SWF 
Version 

Flash Player 9 or lower  
(NetCast 2.0 does not support Flash Player 10)   

ActionScript AS 2.0 

Graphics 
Resolution 1280 x 720 

Type of images loadable during runtime PNG , JPEG 

Sound 
Format 

MP3, AAC, PCM (Event sound only)  
(NetCast 2.0 does not support AAC) 

Sample rate 16 kHz, 32 kHz, 44.1 kHz 

Flash Video 

SW Codec  On2 , Sorenson - Low quality video  

HW Codec  H.264 (with AAC audio only) 

- Recommended video resolution Up to FHD (1080 p) 
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Type Item LG Smart TV Emulator 2011 

- Recommended audio sample rate 44.1 kHz 

Streaming Protocol HTTP(s) RTMP/RTMP-e 

Security 
RTMP-e, FlashAccess3.0 
(NetCast 2.0 does not support FlashAccess3.0) 

 

Differences from the TV 

LG Smart TV Emulator 2011 has some differences from LG Browser and Flash player on the TV. Developers should 
keep in mind these differences when they test applications on the emulator. 
The table below lists LG Smart TV features that work differently on the emulator and on TV.  
 

[Table] Differences between Emulator and TV 

Feature LG Smart TV Emulator 2011 DTV 2011 

Performance  
Depending on the PC where the 
emulator is running. 

Depending on the target DTV 

Resource size 

Depending on the memory of the PC. 
Note that the memory of the PC is 
much greater than the one on the 
target DTV board. 

Depending on the memory of the target 
DTV 

Image decoder prebuilt libjpeg7-win32 patched JPEGsrc. v6b 

DRM Not supported 
WM DRM-PD Version 10 and WideVine 
DRM are supported. 
PlayReady DRM is not supported.  

Magic Remote 
Supported limitedly  
- Acceleration sensor is not supported. 

Supported 

Media player 
Refer to the List of Supported 
Codecs and Containers. 

 

Flash Supported Supported 

HTML5 Partly Supported Supported 

PLEX Supported Supported 

TP Streaming Supported Supported 

USB Emulation Supported Supported 

DTV General Supported Supported 

EMF Supported Supported 

DLNA Not supported Supported 

DVR Ready Not supported Supported 

3DTV Not supported Supported 

C Native Not supported Supported 

LG Apps Not supported Supported 

My Apps Not supported Supported 

SDP Client Not supported Supported 

 

Note  

Between the DTV and emulator, there may be performance difference depending on CPU speed and video memory 
of the PC that developers use (e.g., .graphic rendering speed and quality, video streaming speed). 

 

Getting Started 

This chapter covers the user interface of LG Smart TV Emulator 2011 and how to navigate in the emulator. Also, 
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menu descriptions on emulator are provided. 
 
This section includes the following sections. 
 Starting and Exiting the Emulator 
 User Interface of the Emulator 
 Navigation in the Emulator 
 Menu Description 

 

Starting and Exiting the Emulator 

Select [Start > Program > LG Smart TV SDK > LG Smart TV Emulator 2011] to launch the emulator after installing 

it.  
 
When the emulator starts running, the TV and IR Remote emulator run by default. Press the [POWER] button in the 

remote control to launch the emulator. 
 

 
 

To exit the emulator, press the [ x ] button on the top right or select [Exit] in the emulator menu. Then, the following 

pop-up window appears. 
 

 
 

Press the [Yes] button to exit the emulator. 

 

User Interface of the Emulator 

LG Smart TV Emulator 2011 basically consists of the main window and IR Remote emulator. All of navigation of 
emulator is done by the remote control and PC mouse. (see Navigation in Emulator) 
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 [Figure] User Interface of LG Smart TV Emulator 2011 

 
The following describes each part of the emulator. 
 

① Main window 

The main window that displays the operation of the emulator. The emulator has the same resolution as the TV screen. 
You can zoom in/out the size of the main window in the emulator menu. 
 

② Emulator menu 

Click the title to open the emulator menu. (see Emulator Menu.) 

 

③ IR Remote emulator 

Emulates the TV IR Remote. (see IR Remote Menu) 

 

④ Minimize and Exit 

Press the  button to minimize the emulator window; press the  button to exit the emulator. 
 

Navigation in the Emulator 

In order to navigate, LG Smart TV Emulator 2011 uses a remote control as you do with the target DTV, but it does not 
support a keyboard. Users of the TV-based web and Flash contents may not have mouse and keyboard. Therefore, 
you might need to estimate usability of the content without mouse or keyboard – with IR Remote emulator. 
 
When you want to emulate navigation using the Magic Remote, you need to use your PC mouse. Move the cursor 
using your mouse on the emulator screen.  
 

Note  

To learn about IR Remote menu, see IR Remote Menu. 

 
 
 

Menu Description 

This chapter describes the functions of the emulator menu and remote control menu provided by LG Smart TV 
Emulator 2011. 
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Emulator Menu 

To display the emulator menu, click the top left of the emulator main window. Run the basic functions of the emulator 
and set the options using this menu. 
 
Click "DTV Emulator" on the top left of the emulator main window to display the following emulator menu. 
 

 
 

[Figure] Emulator Menu of LG Smart TV Emulator 2011 

The following table describes the hierarchy of the emulator menu in LG Smart TV Emulator 2011. 
 

[Table] Emulator Menu Description (LG Smart TV Emulator 2011) 

Menu Description 

Screen Size 

50% Shrinks the emulator window. 

75% The default size of the emulator window. 

100% Expands the emulator window. (1366 x 768) 

Full Screen Opens the emulator window in full screen mode. 

Options 

TP Data 
Runs the Transport Stream file. 
See TS Emulation. 

External Device 
Emulates external device function regarding to the USB. 
See USB Emulation. 

Proxy Configuration 
If you use a proxy, enter the proxy server address and port number. 
See Proxy Configuration. 

Run Flash… 
Opens a flash file (.SWF) to be played in the Flash player. 
See Flash Player Emulation. 

Run Browser(Open URL)… 
Enters the URL address to access in the browser. 
See Browser Emulation. 

Terminate Currently Running App Kills the currently running application. 

Show Log 
Shows log message of Browser or Flash application. 
See Section Log. 

Overscan Area ON 
In Blu-ray Player, overscan area of the screen should be considered. 
This area must be blank in your application.  
See Overscan Area. 

Remote Control 
Run or hide the IR Remote emulator. 
See IR Remote Menu. 

About NetCast 2.0 Version of LG Smart TV Emulator 

Exit Exits the emulator. 
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IR Remote Menu 

To emulate the TV IR Remote and its functions, LG Smart TV Emulator 2011 provides the IR Remote emulator. The 
IR Remote emulator is displayed in a separate window, and you can drag it to the desired position on your desktop. 
 

 
 

[Figure] IR Remote of LG Smart TV Emulator 2011 

 
The following table describes the buttons on the remote control. 
 

[Table] IR Remote Menu  (LG Smart TV Emulator 2011 

Button Description Disabled/Enabled 

① [POWER]: Turns the emulator on/off. Enabled 

② 

 [ENERGY SAVING]: Sets the energy saving mode. 
 [AV MODE]: Toggles between preset Video and Audio modes. 
 [INPUT]: Rotates through inputs. Also turns the TV on from standby. 
 [TV]:  Returns to the last TV channel. 

Enabled  
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Button Description Disabled/Enabled 

③ 

 [0~9]: Selects channel numbers. 

 [−] : Shows the program list. 

 [FLASHHBK]: Returns to the previous channel. 

Enabled 

④ 

 [FAV]: Sets the desired favorite channels list. 
 [RATIO]: Selects your desired Aspect Ratio of picture. 
 [MUTE]: Switches the sound on/off. 

 [VOL +,−]: Adjusts the volume. 

 [CH +,−]: Changes the channel. 

Enabled 

⑤ 
 [Premium]: Shows the premium contents. 
 [HOME]: Enters into the Home menu.  
 [Q.MENU]: Opens the list of Quick Menu options. 

[Premium] button is disabled. 
The others are enabled. 

⑥ Navigation keys for the menu. Press [ENTER] to choose the menu. Enabled 

⑦ 
 [BACK]: Returns to the previous menu or exit from current menu. 
 [Widget]: The function depends on regions.  
 [EXIT]: Returns to the previous menu or exit from current menu. 

[Widget] button is disabled. 
The others are enabled. 

⑧ 
[RED,GREEN,YELLOW,BLUE]: If necessary, DTV content explains 
the color icons for a specific feature. 

Enabled 

⑨ 

 [STOP]: Stops DivX. 
 [PLAY]: Plays DivX. 
 [PAUSE]: Pauses DivX. 
 [REWIND]: Rewinds DivX. 
 [FASTFORWARD]: FastForwards DivX. 

 [ⓢIMPLELINK]: Links to the TV, DISC, VCR1, HDD Recorder and 

Speaker. 
 [INFO]: Channel Information. 

[STOP], [PLAY], [PAUSE], and 
[INFO] Buttons are enabled. 
The others are disabled. 

 

Main Functions of Emulator 2011 

This chapter introduces the main functions of the emulator such as Browser and Flash player emulation. It also 
describes on how to use basic DTV emulation functions. 
 
Main Functions of Emulator 2013 are as follows: 
 Proxy Configuration 
 Browser Emulation 
 Flash Player Emulation 
 Overscan Area 
 TS Emulation 
 USB Emulation 
 Log 

 

Proxy Configuration 

LG Emulator supports proxy configuration.  
 

Caution 

You should set up your proxy server before turning the emulator on. If you change proxy configuration at runtime, 
the emulator needs to be rebooted. 

 
1. Press [Proxy Configuration] in the emulator menu after starting the emulator. 
 
2. If you use a proxy, enter the proxy server address and port number. 
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If you do not use proxy, select [Don’t use proxy]. 
 
3. After completing the proxy configuration, press the [POWER] button in the remote control to turn the emulator on. 
 

 
 

Browser Emulation 

LG Browser is a web browser for digital TV sets. LG Smart TV Emulator 2011 can open URLs and local URLs on PC 
for testing web content. Since the emulator uses the same source code as the LG Browser running on the DTV, it 
reproduces its behaviour quite accurately. Because of the differences between PC and TV platforms, the emulator 
has differences from the TV. (See Differences from the TV.) 

 
 Opening URLs: Testing a server-based URL 
 Opening Local URLs: Testing a local URL 
 

Opening URL 

Perform the following steps to open a URL.  
 
1. Press [Run Browser(Open URL)…] in the emulator menu. 

 
The following window appears in which you can enter a URL. Enter the URL and click [GO] to open the URL. 
To delete the URL from history, select URL and click the [Delete From History]. 

 

 
 
2. Enter the URL address you want to access and press the [GO] button. For example, enter http://www.lg.com. 

 
3. Then, you can view the website of the URL in the emulator's browser as shown below. 
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4. Once you have opened a URL, you cannot enter another URL. You need to exit first by pressing [EXIT] in the IR 

Remote emulator and reenter the URL to open another one. 
 

Opening Local URL 

LG Smart TV Emulator 2011 supports local URL. The absolute path relates to the executable file of the installed 
emulator. This function is not supported on the LG Browser running on the real TV. Content developers can test the 
developed content stored in their PC. 
 
1. Press [Run Browser(Open URL)…] in the emulator menu. Then, the window appears, in which you can enter 

local URL or select a file path from history list. If the absolute path is C:\html\a.html, for example, then you must enter 
the file:///c:/html/a.html. Or, select local URL from the history list. 

 
2. Press the [GO] button to open the browser file stored on your PC. The URLs that you entered will be added in the 
history. To delete the URL, select URL and click the [Delete From History] button. 

 
3. Then, you can view the page of the local URL in the emulator's browser. 
 
4. Once you have opened a local URL, you cannot enter another URL. You need to exit first by pressing [EXIT] in the 

IR Remote emulator and reenter the URL to open another one. 
 

Flash Player Emulation 

With the emulator, you can open and execute a Flash file to test it on your PC first. Because of the differences 
between PC and TV platforms, the emulator has Differences from the TV. (See Differences from the TV.) 

 

Note  

Refer to Specifications for LG Flash Player specifications and “Flash Content Design Guide for HDTV” in the  
[DISCOVER > Legacy Platform (NetCast) > Technical Notes] at LG Developer website for Flash content design 

guidelines. 

Running Flash Files 

1. In LG Smart TV Emulator 2011, press [Run Flash…] in the emulator menu. 

 
Then, the following window appears, in which you can select a Flash file (.SWF). 
If you select the [Fit To Flash Dimension] check box and set the resolution of the flash file, the flash file is opened in 
full screen mode. 
If you do not select the [Fit To Flash Dimension] check box, the default resolution of full screen mode is 1280x720.  
For example, if the resolution of the flash file is 960x540 and you do not select the [Fit To Flash Dimension] check 
box,  the flash file is opened in top-left corner of the full screen and the size is smaller than the full screen.  
 
SDK V1.3.0 (and above) does not have a backward compatibility with SDK V1.2.0 and lower versions. 
[SWF developed by LG Smart TV SDK 1.3.0 and above] check box should be selected in order to run the flash file 
developed by SDK V1.3.0 and above versions. 
By default, check box is selected. 
On the contrary to this, the check box should not be selected to run the flash file developed by SDK V1.2.0 and lower 

http://webostv.developer.lge.com/discover/netcast/technical-notes/
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versions. 
 

 
 
2. Press the [RUN] button after entering the file path of the Flash file stored on your PC.  

 
3. Then, you can view the opened file in the emulator's Flash player as shown below. 
 

 
 

Overscan Area 

In Blu-ray Player, overscan area of the screen should be considered.  
This area must be blank in your application.  
 
Press [Overscan Area ON] in the emulator menu. 

 

 
 
Then, the following window appears. You can check the overscan area. 
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For more information, refer to the “UI Guidelines” in Developing > Designing section in this Library. 
 
 

TS Emulation 

LG Smart TV Emulator 2011 can emulate DTV basic functions regarding broadcasting. 
 

Note  

TS file is MPEG transport stream which is a standard format for transmission and storage of audio, video and data, 
and is used in broadcast system such as DVB and ATSC. In order to get a TS File, you can save broadcast stream 
using TV  tuner Card or can download a sample TS file using the internet. 
Currently, LG Smart TV Emulator 2011 supports only DVB TS file not ATSC. 

 

Running the TS File 

With the emulator, user can add and delete a TS file in LG Emulator for Smart TV. If TS file is added, a physical 
channel for broadcasting is added automatically.  
To add a TS file, follow below steps: 
 
1. Select [Options > TP Data] in the emulator menu. Then, the following window appears. 
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 [Add TS File…]: Adds a TS File. 
 [Remove]: Removes a TS file. 

 
2. Click [Add TS File…] button. Then, the following window appears. 

 

 
 
Select TS file that you want to play ([File Name] field (browse for file)). Then, select [Mode] (currently, only DVB is 
supported) and [Country] that should be same as setting in DTV (DTV Menu > OPTION > Country). 
 
Press [OK] button. 

 
3. Press [Home] button on the IR Remote emulator.   

 

 
 
Then, you can see the Home board as follows (only in LG Smart TV Emulator 2011). 

 

 
 
4. Select [SETUP] on the Home board. Then, the Setup menu window appears. 
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5. Select [Auto Tuning] to tune the channel. 

 

 
 
6. If channel tunning is completed, the emulator will play TS. 
You can change the channel using remote control. 
 

 
 

USB Emulation 

LG Smart TV Emulator 2011 can emulate USB feature. It detects and plays media files from the specified directory. 
Only USB drive needs not necessarily be specified. 
Any system directory can be specified. 



 

 56 

 

Note  

This feature does not support detecting physical USB device connection. It emulates virtually USB device 
connection from the specified directory path. 

 

Connecting the USB Device 

With the emulator, you can point the directory which contains media file such as video, audio, image files. If you 
configure a directory, the emulator treats the path as a USB external storage path. To configure a USB Emulation 
path, perform the following steps: 
 
1. Select [Options > External Device] in the emulator menu. Then the following window appears. 

 

 
 
 [Browse…]: Sets a specific directory which contains media files. 
 [Connect USB]: Occurs USB connection event virtually in the emulator. 
 
2. Click [Connect USB] button. 

Then, the following window appears. Press Movie, Photo, or Music icon according to the media type that is contained 
in the directory. 
 

 
 
3. Then, the following window appears. You can play media file. 
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Log 

LG Smart TV Emulator 2011 can show log message of Browser or Flash application. 
 

Note  

In flash, TRACE can be used to print log message. In web contents, console.log can be used to print log message. 

 
1. Select [Show Log…] in the emulator menu. Then the following window appears. 

 

 
 

2. Log message is shown when an application is running. 
 

 
 
 [Open]: Reads the log message from the log file which has *.log extension. 
 [Clear]: Clears the current log message on the window. 
 [Close]: Closes the window. 
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List of Supported Codecs and Containers 

The following table specifies all the supported codecs and containers by emulator and real TV in more detail. 

 

Com
mon 
File 

Exten
sions 

Medi
a 

Cont
ainer 

A/V 
Code

c 

Fo
ur
CC 

DTV 
Targe

t 
Supp
orted

? 

Emul
ator 

Supp
orted

? 

Target 
Description 

Profile/Level 
Support 

Emulator 
Description 

.asf 
.wmv 
.wma 

ASF 
Vid
eo 

VC-1 
Advan

ced 
Profile 

WV
C1 

YES YES 

Only streams 
compliant to SMPTE 
421M VC-1 standard 
are supported. 

Advanced 
Profile @ 
Level 3 
(e.g. 720p60, 
1080i60, 
1080p30) 

 

    
W

MV
A 

YES  
(Read 
Descr
iption

) 

YES 

Only streams 
compliant to SMPTE 
421M VC-1 standard 
are supported. Some 
WMVA streams were 
developed before the 
VC-1 specification 
was finalized.  
These non-compliant 
streams are 
considered 
deprecated by the 
industry and are not 
supported. 

Advanced 
Profile @ 
Level 3 
(e.g. 720p60, 
1080i60, 
1080p30) 

 

   

VC-1 
Simpl
e and 
Main 

Profile
s 

W
MV
3  

YES YES 

Only streams 
compliant to SMPTE 
421M VC-1 standard 
are supported. 

Simple Profile 
@ Medium 
Level 
(e.g. CIF, 
QVGA) 
Main Profile 
@ High Level 
(e.g. 1080p30) 

 

   

Other 
video 
Codec
s like 

MPEG
-1/2/4  

 NO NO 

ASF is a MS 
container format. 
Anything other than 
MS Codecs should 
not be found within an 
ASF file. Non MS 
Codecs within ASF 
are not supported. 

   

  
Aud
io 

WMA 
Stand

ard 

0x0
161 

YES YES     

   

WMA 
9 

Profes
sional 

0x0
162 

YES NO    
.wma format not 
Supported on 
emulator. 

   
WMA 
Lossle

ss 
 NO NO     

   

Other 
audio 
Codec
s like 
AC-3, 
AAC, 
MP3, 

MPEG 
Audio 
Layer 

 NO NO 

ASF is a MS 
container format. 
Anything other than 
MS Codecs should 
not be found within an 
ASF file. Non MS 
Codecs within ASF 
are not supported. 
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Com
mon 
File 

Exten
sions 

Medi
a 

Cont
ainer 

A/V 
Code

c 

Fo
ur
CC 

DTV 
Targe

t 
Supp
orted

? 

Emul
ator 

Supp
orted

? 

Target 
Description 

Profile/Level 
Support 

Emulator 
Description 

I/II 

.divx 
.avi 

AVI 
/DivX 
Media 
Form

at 

Vid
eo 

Divx3.
11 

DIV
3 

DIV
4 

YES YES 

Please note that a 
FourCC value of DIV4 
is not a DivX 4 
stream, but in fact, a 
DivX 3.11 stream. 
DivX 4 streams have 
a FourCC value of 
DIVX. 

   

   
Divx4 
Divx5 
Divx6 

div
x 

DIV
X 

DIV
5 

DIV
6 

DX
50 

YES YES 

MPEG-4 ASP support 
does not include 
global motion 
compensation or 
quarterpel motion 
estimation. Streams 
using this syntax are 
not supported. 

Advanced 
Simple Profile. 
The resolution 
supported is 
chip 
dependent 
with earlier 
chips 
supporting up 
to SD 
resolutions 
(480i) and 
newer chips 
supporting up 
to HD 
(720p/1080i). 

 

   XViD 
XVI
D 

YES YES 

MPEG-4 ASP support 
does not include 
global motion 
compensation or 
quarterpel motion 
estimation. Streams 
using this syntax are 
not supported. 

Advanced 
Simple Profile. 
The resolution 
supported is 
chip 
dependent 
with earlier 
chips 
supporting up 
to SD 
resolutions 
(480i) and 
newer chips 
supporting up 
to HD 
(720p/1080i) 

 

   

Other 
video 
Codec
s like 

MPEG
-1/2 

 NO NO     

   
H.264 
/ AVC 

vss
h 

VS
SH 
AV
C 

avc 
AV
C1 
avc
1 

h26
4 

H2
64 

NOT 
OFFI
CIAL
LY 

SUPP
ORTE

D  
(Read 
Descr
iption

) 

NO 

AVC within AVI files is 
not officially 
supported. It is well 
known in the industry 
that there are 
technical issues 
which make AVC is 
ill-suited for AVI 
encapsulation. This 
creates problems for 
compliance and 
interoperability. That 
is why it is known and 
recommended for 
AVC content to be put 
into other file 

Main Profile 
@ Level 4.1 
High Profile @ 
Level 4.1 
(e.g. 720p60, 
1080i60, 
1080p30) 
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Com
mon 
File 

Exten
sions 

Medi
a 

Cont
ainer 

A/V 
Code

c 

Fo
ur
CC 

DTV 
Targe

t 
Supp
orted

? 

Emul
ator 

Supp
orted

? 

Target 
Description 

Profile/Level 
Support 

Emulator 
Description 

containers such MP4 
and MKV.  There is 
Code to attempt to 
handle AVC within 
AVI files but some 
streams will work and 
others will not. 

  
Aud
io 

MPEG
-1 

Layer 
I, II 

0x0
050 

YES YES     

   

MPEG
-1 

Layer 
III 

(MP3) 

0x0
055 

YES YES     

   AC-3 
0x2
000 

YES YES     

   
WMA 
Stand

ard 

0x0
161 

YES YES     

   

WMA 
9 

Profes
sional 

0x0
162 

YES NO     

   

Other 
audio 
Codec
s like 
AAC, 
DTS, 
PCM 

 NO NO     

.mkv MKV 
Vid
eo 

H.264 
/ AVC 

V_
MP
EG
4/I
SO
/AV
C 

YES YES 

Most of the MKV 
content available is 
encoded by the open 
source x264 Codec, 
the default 
configuration labels 
streams as Level 5.0 
(e.g. highest level), 
the video decoder 
only supports up to 
Level 4.1 and does it 
is best to decode 
Level 5.0 streams 

Main Profile 
@ Level 4.1 
High Profile @ 
Level 4.1 
(e.g. 720p60, 
1080i60, 
1080p30) 

.Mkv format is 
not supported in 
emulator.  

   

Other 
video 
Codec
s like 

MPEG
-1/2/4 

 NO NO 
Need sample streams 
to test 

   

  
Aud
io 

AAC 
A_
AA
C 

YES YES  
AAC-LC and 
AAC-HE 

 

   AC-3 
A_
AC
3 

YES YES     

   

MPEG
-1 

Layer 
III 

(MP3) 

A_
MP
EG
/L3 

YES YES     

   MPEG A_ YES YES     
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Com
mon 
File 

Exten
sions 

Medi
a 

Cont
ainer 

A/V 
Code

c 

Fo
ur
CC 

DTV 
Targe

t 
Supp
orted

? 

Emul
ator 

Supp
orted

? 

Target 
Description 

Profile/Level 
Support 

Emulator 
Description 

-1 
Layer 

I, II 

MP
EG
/L1 
A_
MP
EG
/L2 

           

.ts 
.trp 
.tp 

.m2ts 

MPE
G-2 
TS 

(Tran
sport 
Strea
m), 

stand
ard 
188 
byte 
TS 
and 

time-
stamp

ed 
192 
byte 
TS 

Vid
eo 

H.264 
/ AVC 

 YES YES  

Main Profile 
@ Level 4.1 
High Profile @ 
Level 4.1 
(e.g. 720p60, 
1080i60, 
1080p30) 

.ts, .trp, .tp 
and .m2ts 
formats are not 
supported on 
emulator. 

   
MPEG

-2 
 YES YES  

Main Profile 
@ High Level 
(e.g. 720p60, 
1080i60) 

 

   VC-1  YES NO 

Only streams 
compliant to SMPTE 
421M VC-1 standard 
are supported.  
Encapsulation must 
abide by SMPTE 
RP227 specification. 

Simple Profile 
@ Medium 
Level 
(e.g. CIF, 
QVGA) 
Main Profile 
@ High Level 
(e.g. 1080p30) 
Advanced 
Profile @ 
Level 3 
(e.g. 720p60, 
1080i60, 
1080p30) 

 

  
Aud
io 

MPEG
-1 

Layer 
I, II 

 YES YES     

   

MPEG
-1 

Layer 
III 

(MP3) 

 YES YES     

   AC-3  YES NO     

   

DDP 
(Enha
nced 
AC-3) 

 YES NO     

   AAC  YES YES  
AAC-LC and 
AAC-HE 
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Com
mon 
File 

Exten
sions 

Medi
a 

Cont
ainer 

A/V 
Code

c 

Fo
ur
CC 

DTV 
Targe

t 
Supp
orted

? 

Emul
ator 

Supp
orted

? 

Target 
Description 

Profile/Level 
Support 

Emulator 
Description 

.vob 

MPE
G-2 
PS 

(Progr
am 

Strea
m), 

VOB, 
SVCD 

Vid
eo 

MPEG
-1 

 YES NO    
.vob is not 
supported in 
emulator. 

   
MPEG

-2 
 YES YES  

Main Profile 
@ High Level 
(e.g. 720p60, 
1080i60) 

 

  
Aud
io 

AC-3  YES NO     

   

MPEG
-1 

Layer 
I, II 

 YES YES     

   
DVD-
LPCM 

 YES NO     

.mpg 
.dat 

MPE
G-1 

Syste
ms, 
VCD 

Vid
eo 

MPEG
-1 

 YES YES    
.mpg, .dat are 
not supported in 
emulator. 

  
Aud
io 

MPEG
-1 

Layer 
I, II 

 YES YES     

.mpg 

.mpe 
.mpeg 

Unkn
own 

     

Note that these file 
extensions do not 
uniquely specify 
whether the contents 
are TS, PS or ES. 
These files are 
supported only if the 
decoder is configured 
properly for TS, PS or 
ES. The decoder 
needs to know this 
information and will 
not determine it on its 
own. See other rows 
for support 
information. 

   

.mp4 

.m4a 

.m4v 
MP4 

Vid
eo 

H.264 
/ AVC 

avc
1 

YES YES  

Main Profile 
@ Level 4.1 
High Profile @ 
Level 4.1 
(e.g. 720p60, 
1080i60, 
1080p30) 

 

   
MPEG
-4 Part 

2 

mp
4v 

YES YES 

MPEG-4 ASP support 
does not include 
global motion 
compensation or 
quarterpel motion 
estimation.  Streams 
using this syntax are 
not supported. 
 
Motion compensation 

Advanced 
Simple Profile 
The resolution 
supported is 
chip 
dependent 
with earlier 
chips 
supporting up 
to SD 
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Com
mon 
File 

Exten
sions 

Medi
a 

Cont
ainer 

A/V 
Code

c 

Fo
ur
CC 

DTV 
Targe

t 
Supp
orted

? 

Emul
ator 

Supp
orted

? 

Target 
Description 

Profile/Level 
Support 

Emulator 
Description 

describes a picture in 
terms of the 
transformation of a 
reference picture to 
the current picture. 
The reference picture 
may be previous in 
time or even from the 
future. When images 
can be accurately 
synthesized from 
previously 
transmitted/stored 
images, the 
compression 
efficiency can be 
improved. 
 
Quarter Pixel Motion 
Search Precision 
(QPEL): Basically 
most MPEG-4 
Codecs by default 
detect motion 
between two frames 
down to half a pixel 
(HalfPel). Now with 
QuarterPel you can 
detect motion that is 
only a quarter of a 
pixel per frame, 
effectively doubling 
precision! 
practically this means 
that you will get a 
much sharper image 
with QPEL. 
 
Global Motion 
Compensation 
(GMC): 
GMC detects if there 
is an amount of 
motion big parts of 
the frame have in 
common. If that’s the 
case GMC kicks in, 
using a single motion 
vector for all similar 
parts of the frame 
instead of multiple 
ones. Practically this 
helps saving bits 
when panning, zoom 
or rotation occurs 
(depending on how 
good the GMC 
implementation 
is/offered warp 
points), bits which 
than can be used 
somewhere else, for 
example where they 
bring more 

resolutions 
(480i) and 
newer chips 
supporting up 
to HD 
(720p/1080i) 
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Com
mon 
File 

Exten
sions 

Medi
a 

Cont
ainer 

A/V 
Code

c 

Fo
ur
CC 

DTV 
Targe

t 
Supp
orted

? 

Emul
ator 

Supp
orted

? 

Target 
Description 

Profile/Level 
Support 

Emulator 
Description 

sharpness. 

   H.263 
s26
3 

YES NO 
Profile 0, Level 70. No 
Annex supported 

  

   

Other 
video 
Codec
s like  

MPEG
-1/2, 
VC-1 

 NO NO 
No standard 
specifying header. 
No sample files. 

  

  
Aud
io 

AAC 
mp
4a 

YES YES  
AAC-LC and 
AAC-HE 

 

   

Other 
audio 
Codec
s like 
AC3, 
DTS, 
MP3 

 NO NO 
No standard 
specifying header. 
No sample files. 

   

.mov QT 

Aud
io/V
ide
o 

  NO NO 

Most QuickTime 
streams appear to be 
MPEG-4 Part 12. 
Please see MP4 
section of list 
supported audio/video 
Codecs. 

  
.mov format is 
not supported in 
emulator. 

           

.f4v 

.f4a 
.flv 

Flash 
forma

ts 

Aud
io/V
ide
o 

  YES YES 

Please see MP4 
section of list 
supported audio/video 
Codecs Support 
limited to LPCM 

  

Flash engine 
supports flash 
playback such 
as as .f4v, .f4a 
and .flv. 
 
These formats 
are not 
supported using 
open API. (e.g., 
playClipFile) 

.wav WAV 
Aud
io 

LPCM 
0x0
001 

NO NO   
.wav format is 
not supported in 
emulator. 

.mp3 MP3 
Aud
io 

MPEG
-1 

Layer  
III 

 YES YES    
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Using LG Resource Monitor 

LG Resource Monitor is a tool that displays the resource usage status of the connected device. Currently, only 
emulator on local PC can be monitored using LG Resource Monitor. Real target monitoring will be supported in the 
future. 
 
 
Click [LG Smart TV SDK > LG SDK Tools > LG Resource Monitor] from the Start menu. LG Resource Monitor tool 

consists of three areas. Each area will be described in the following sections. 
 

 
 
 Device View 
 CPU / Memory / System Information 
 Log View 

 

Device View 

In Device view, you can connect (add) device and select processes to monitor. 

• : Connect (add) a device to monitor.  

• : Disconnect the device. (Disabled when no device is connected.) 

 

1. Press , then, the following window appears. The IP and Port value for emulator are set default. To monitor the 
emulator on local PC, click [Add]. 
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2. Select the device to connect and click [Connect]. To delete the device from this list, press  icon. 

 

 
 
3. Process list of the connected device is shown. Check on the process to monitor. (Multiple selection is available.) 
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CPU / Memory / System Information 

CPU View shows the CPU usage of the checked process. If you checked multiple processes, the chart will show the 
CPU usage information for each process. 
 

 
 
Memory View shows the memory usage of the checked process. If you checked multiple processes, the chart will 
show the memory usage information for each process. 
 

 
 
System Information displays the system information of the connected device. 
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Log View 

Displays receiving log messages from the connected device on the “Log” tab. “Log” tab is default log viewer and it 
cannot be edited or closed. You can add a log filter that will display filtered messages in the new log tab. 

 
 

• : Add Filter 

• : Edit Filter (Disabled if “Log” or “Import Log” tab is selected.) 

• : Close Log (Disabled if “Log” tab is selected.) 

• : Clear Log 

• : Export Log 

• : Import Log 

 

Click  to add a log filter. If user adds a log filter, a new log tab named <Filter Name> is added next to the “Log” 
view. Log messages filtered by new log filter are displayed on this tab. 
 
Set filter name and text, and click [OK]. 

 

 
 

• Filter Name: A filter name that will be shown on the log tab. 

• Filter Text: Text to filter from log messages. (e.g. Enter ‘1’ to see log messages including ‘1’ only) 

 
New filter and filtered messages are shown as below. 
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Troubleshooting 

Q1) Emulator storage is displayed in an unreadable state on Virtual Box. 

 
A1) Install the SDK again after uninstalling the SDK. If the problem cannot be solved after re-installing the SDK, 
follow the next steps. 
 
1. Uninstall the SDK. 
2. Execute Oracle VM VirtualBox Manager from Start menu > Oracle VM VirtualBox. 
3. An Unreadable state is displayed in Storage section as red box below. 
 

 
 
4. Click [File > Virtual Media Manager] menu. 
 
5. In Virtual Media Manager window, release “lg_smart_tv_vm_2012_common.vmdk" and 
“lg_smart_tv_vm_2012_platform.vmdk" manually, then remove them on the list. 
 

Note 

Before releasing “lg_smart_tv_vm_2012_common.vmdk" and “lg_smart_tv_vm_2012_platform.vmdk", the LG Smart 
TV Emulator must be powered off. 
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5. Install the LG Smart TV SDK again. 
 
 
Q2) When executing the emulator, application is automatically terminated or loses its mouse pointer!! 

 
A2) Delete snapshot manually on the list by pressing <Ctrl>+<Shift>+D and execute the emulator again. 
 
 
 
 


