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Using SDK 
 
This document includes the following section about using LG Smart TV SDK. 
 
Introduction to LG Smart TV SDK 

This section introduces the LG Smart TV SDK. 
 
Release Notes 

This document describes what is new in the latest LG Smart TV SDK, including bug fixes and new features, and 
references to the relevant technical documentation. 
 
Installation Guide 

This section includes the following guides to explain how to install the LG Smart TV SDK on your PC. 
 
Creating the Project 

This section describes how to start developing web application with LG IDE.  
 
Using LG WYSIWYG Editor 

This section describes how to use WYSIWYG Editor included in LG IDE. 
 
Utilities 

This section introduces helpful utilities provided in LG IDE. 
 
Troubleshooting 

This section describes solutions for installation and configuration in LG Smart TV SDK. 
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Introduction to the LG Smart TV SDK 

LG Smart TV SDK is a tool that provides developers with LG IDE for web application development, emulator for 
testing application, and related documents. Developers can create applications for LG Smart TV easily using this 
SDK. 
 
The SDK package consists of the following components: 
 
 LG IDE 
 LG Smart TV Emulator 2011 
 LG Smart TV Emulator 2012 
 LG Smart TV Emulator 2013 
 LG SDK Tools - LG Configuration Tool, LG Resource Monitor (LG Digital Signing Tool is not supported for app 
packaging anymore. Do not use it.) 
 Link to the documents 
 
You can download the latest version of the SDK from [DISCOVER > Legacy Platform (NetCast) > SDK] menu in LG 

Developer website. 
 

http://webostv.developer.lge.com/discover/netcast/sdk
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Release Notes 

This document describes what is new in the LG Smart TV SDK, including bug fixes and new features, and references 
to the relevant technical documentation. 
 
 New Features 
 API Differences 
 Known Issues 
 Bug Fixes 

 

New Features 

V3.0.0 
 

1) LG Web IDE 
 The LG Smart TV Emulator 2013 is added in ‘Emulator’ field on “Run Configuration” and “Debug 

Configuration” menus. 
 The target TV list (LG Smart TV 2012, LG Smart TV 2013) is added in the ‘Real TV’ field on “Debug 

Configuration” and the ‘Target’ field on “Export App Test” menus. LG IDE checks the target TV and 
executes the different webkit and inspector according to the selected target TV. 

 LG IDE supports the safety zone on designer (WYSIWYG) editor so you can check the actual area 
displayed in emulator or real TV. 

 LG IDE sets some fields related to HTML to ‘ignore’ by default. These are to avoid the errors related 
to unknown tags or attributes. 

 ‘JSON File’ menu is added to the toolbar and context menu. 
 
2) LG Smart TV Emulator 2013 

 Emulator is provided in three versions: 
 LG Smart TV Emulator 2011 (NetCast 2.0) 
 LG Smart TV Emulator 2012 (NetCast 3.0) 
 LG Smart TV Emulator 2013 (NetCast 4.0) 

 
3) LG Smart TV SDK 3.0 does not support Flash and AIR. 
 
4) LG Smart TV Emulator 2013 does not support Flash/AIR and PLEX. 
 
V2.4.0 
 

1) LG Web IDE 
 LG IDE Plugin for web application development in Eclipse Java EE is supported. 
 Importing Custom Template is added to the LG UI Template. 
 LG LG Web Page Designer (WYSIWYG) Editor is added. 
 LG API Validator is added. 

 

2) LG Smart TV Emulator 2012 
 HLS (HTTP Live Streaming) protocol is added. 

 
V2.2.1 
 

1) LG Web IDE 
 JSLint and CSSLint are added. 
 Installer for multiple user accounts is supported in Linux and Mac OS. 
 Web type in [Export App Test] menu is added. 
 ‘Servers’ view is supported. 

 
V2.2.0 
 

1) LG Web IDE 
 LG IDE is newly provided for web application development. 

 Running and debugging application on Real TV is supported in IDE. 
 LG Web UI components are added in LG WYSIWYG Editor. 
 Debugging using Web Inspector on LG Smart TV Emulator 2012 and real TV is added. 

 Supports multiple Operating System. Six installation versions for SDK are provided.  
 32-bit and 64-bit versions of Windows, Linux, and Mac 

 

2) LG Smart TV Emulator 2012 
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 [Take Screenshot] is added. 
 [Test Media File] is added. 
 [Send Voice Input] is added. 

 
V2.1.0 
 

1) Emulator 
 LG DTV Emulator NetCast 3.0 (2012 VM) is provided newly. This emulator is based on Linux and 

VirtualBox should be installed on your PC to operate this emulator normally. VirtualBox is a 
virtualization application which can run Linux on your Windows PC. 

 
2) LG IDE Plugin for Flash Application Development 

 AIR file packaging is automatically done by clicking the “Step-2. Build and Run Over Emulator” 
command from LG IDE plug-in menu in Adobe Flash Professional CS. 

 
V2.0.1 
 

1) Emulator 
 AIR 3.0 (AS 3.0) is supported in LG DTV Emulator NetCast 3.0 (2012). 

 
V2.0.0 
 

1) LG IDE Plugin for Web Application Development 
 Web page creation from LG UI Template is supported. 
 LG WYSIWYG Editor is supported. 
 Custom components importing is supported. 

 
2) LG IDE Plugin for Flash Application Development 

 NetCast 3.0 features are added: 
 SWF and AIR applications and Flash Player features are supported. 
 New fonts are added. 
 Wheel feature is added. 

 

3) Common 
 LG Resource Monitor is supported. 
 ‘Adobe Air’ is added in the application type of LG Configuration Tool. 

 

4) Emulator 
 Emulator is provided in two versions: 

 LG Smart TV Emulator 2011 (NetCast 2.0) 
 LG Smart TV Emulator 2012 (NetCast 3.0) 

 
V1.5.0 
 

1) Installation 
 64 bit Operating System is supported. 
 Installation path setting is supported.  
 Icons and images in Installshield are upgraded. 

 
2) SDK 

 Advertisement APIs and sample applications are added. 
 Added sample applications: Banner/Video Advertisement Integration (Flash/Web) 
 Application Testing with USB on real TV is supported. 
 Configuring SDK path is supported. 

 

3) LG IDE plugin for Web application development 
 Web API tutorial samples and documents are added. 
 W3C widget package importing function is added. 
 JSON editor is added. 
 Preview on Safari browser is added. 
 Icons and images in IDE are upgraded. 

 
4) Emulator 

 Supports elements of HTML5 which are currently supported by the NetCast platform. 
 The following buttons of IR Remote are enabled: [STOP], [PLAY], [PAUSE], and [INFO] 

 

API Differences 

V3.0.0 
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1) LG Web Open API 
 window.NetCastSetAutoMouseOff and window.NetCastSystemKeyboardVisible are added in NetCast 

API. 
 support3DMode is added, and support3DMode.from_2d_to_3d, support3DMode.side_by_side, 

support3DMode.side_by_side.rl, support3DMode.top_bottom, support3DMode.checker_bd are 
removed in Device Info Plugin and API. 

 
V2.4.0 
 

1) LG Web Open API 
 onDRMRightsError is added in MediaPlayer events. 
 DRMAgent Plugin and API are added. 

 
V2.2.0 
 

1) LG Web Open API 
 AppToApp, Sound, SNS, and Membership, Plugin and API are added. 
 getSrcInfo is added in Media Player API (Method). 
 getLocalTime, getSystemTime, and pentouchInfo are added in DeviceInfo API (Methods). 
 SDKVersion, supportVoiceRecog, supportPentouch, timeZone, platform, and chipset are added in 

DeviceInfo API (Properties). 
 getNextProgram, getProgramList, getProgramCount, setChannel, getAllChannelList, getChannelList, 

getChannelCount, and getChannelState are added in Broadcast API (Methods). 
 language is added in Voice Recognition API (Property). 

 

2) LG Advertisement API 
 The InterstitialAd class is used to easily add a video ad at any time in web app. 
 VideoAdMediaPlugin class is used to play a video advertisement using media plugin object. 

 
V2.1.0 
 

1) LG Web Open API 
 window.NetCastEnableChannelKey is added in NetCast API. 
 getCurrentChannelName, getCurrentProgram, getCurrentChannelNumber, isChannelMapEmpty, 

isTunerInput, isDvb are added in Broadcast API. 
 onchannelchange and onnosignal are added in Broadcast events. 
 Voice Recognition Plugin and API are added. 

 

2) LG Flash Open API for Flash Application 
 getAppArgument, getStorageSize, and createPopup are removed. 

 

3) LG Advertisement API 
 Usage of the parameter ‘bannerStyle’ in BannerAd class is changed. Developers can choose the 

banner size from specified table and set location within specified range. 
 
V2.0.1 
 

1) LG Flash Open API for AIR Application 
 LocaleInfoType, DisplayMode, MessageType, OSDType, SupportType, Input3DMode, 

getCommonPath, setDisplayResolution, getDisplayResolution, setDisplayMode, getDisplayMode, 
setDisplayArea, getCapability, getStorageSize, setMotionRemoteMode, setScreensaverOff, 
set3DMode, get3DMode, and getSystemInfo are removed. 

 

2) LG Flash Open API for Flash Application 
 LocaleInfoType, PanelAttributeType, PanelBacklightType, PanelResType, PanelType, RemoconType, 

and getChannelList, setMute, getMute, getDisplayArea, getAspectRatio are removed. 
 
V2.0.0 
 

1) LG Flash Open API for AIR (AS 3.0) application is added. 
 

2) LG Flash Open API for Flash Application 
 requestFocus is removed. 
 setReady is removed. 
 getRemoconTypeInfo is removed. 
 releaseFocus is removed 
 getDisplayPanelType is removed. 
 setDimmingOff is removed. 
 getNetworkSettings is removed. 
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3) LG Web Open API  
 Broadcast API is added. 
 NetCast API 

 window.NetCastReturn is removed. 
 window.NetCastEnableNumberKey is added. 

 Media Player API 
 readyState is removed. 
 onReadyStateChange is removed. 

 
V1.5.0 
 

1) LG Flash Open API 
 Application.getAppArgument is added. 
 The following APIs are removed. 

 Control.getEventInfoList is removed. 
 IO.setNetworkSettings is removed. 
 Application.getExecuteArgument is removed. 

 

2) FFC2.0 (Flash Foundation Class) 
 TVSystem.getAppArgument is removed. 

 

3) Ad (Advertisement) API 
 The following APIs are added. 

 Web: BannerAd, VideoAd 
 Flash: BannerAdGadget, VideoAdGadget 

 

 

Known Issues 

None. 
 

Bug Fixes 

V3.0.1 

 
1) Emulator 

 Fix a bug related that the application has been killed when running the Virtual Keyboard in Emulator 
2013. 

 
V2.4.0 

 
1) LG IDE 

 LG WYSIWYG Preview is supported in the WYSIWYG Editor for Linux and Mac. 
 Preview using external web browser is supported for Windows. 

 
2) Flash 

 Flash application development is supported in Mac OS. 
 
V2.2.1 

 
1) LG IDE 

 Unnecessary toolbar and menus are deleted. 
 [New] toolbar icon and [File >LG Web Project] menu launches ‘New LG Web Project’ window instead 

of launching ‘New Static Web Project’ window. 
 [New > Example] in right-click menu from WebContent folder has been deleted. 

 
2) Emulator 

 Fix a bug related to retrieve broadcast information of a week every time a user logs in to the 
emulator. 

 
3) AIR file packaging 

 Compatibility problem of automatic packaged AIR file in some TV models (H12) is solved. 
 Automatic packaging is not supported in Adobe Flash CS 6. 

 
V2.1.1 
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1) LG Flash IDE Plugin 
 Workspace path error occurring problems when clicking “Step-1. Create LGE Project” and “Step-2. 

Building and Run Over Emulator” are fixed. 
 Fixes a bug related to executing Configuration Tool when clicking “Step-3. Configuration Tool”. 

 
V2.1.0 

 
1) Emulator 

 LG Smart TV Emulator 2012 supports AIR 3.0 
 
V2.0.1 

 
1) Log View Message 

 Fixes a bug related to Korean language crash problem. 
 
V1.5.0 

 
1) Emulator 

 Fixes a bug related to display of log messages which has not been shown on some PCs. 
 Hides console window that has been shown with Emulator program. 
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Installation Guide 

This section includes the following guides to explain how to install the LG Smart TV SDK on your PC. 
 
 System Requirements 
 Installation Guide (for Windows) 
 Installation Guide (for Linux) 
 Installation Guide (for Mac) 
 LG IDE Plugin Installation Guide 

 

System Requirements 

LG Smart TV SDK requires the following system requirements. 
 

[Table] Hardware Requirements 

Item Detail 

Processor Pentium 4 2.0 GHz or higher 

RAM 1 GB or higher 

Operating system 
(32bit / 64bit) 

- Windows XP Service Pack 2 or higher 

- Windows 7 

 (In 64bit Windows, some PCs may have Emulator performance down problem.) 

- Ubuntu 10.04, 12.04 

- Ubuntu Mint 13 Maya 

- Mac OS X : Snow leopard or higher 

Screen resolution 1280 x 1024 or higher 

Video memory 256 MB or higher 

 

[Table] Software Requirements 

Category Item Detail 

SDK 

Oracle VirtualBox 
(for LG Smart TV Emulator 2012 and 2013) 

Supported from version 4.1.18 to 4.2.18 
(Version 4.2.18 is recommended and 4.3.x is not 
supported.) 
https://www.virtualbox.org/wiki/Download_Old_
Builds  

Safari (for LG IDE) 
Version 5.1.7 or higher 

http://support.apple.com/kb/DL1531 

Microsoft DirectX  
(for video rendering in LG Smart TV Emulator 2011) 

DirectX End-User Runtimes (June 2010) 

http://www.microsoft.com/en-

us/download/details.aspx?id=8109 

LG IDE Plugin 

Eclipse IDE for Java EE Developers 

Indigo Service Release 2 
http://www.eclipse.org/downloads/download.php

?file=/technology/epp/downloads/release/indigo/

SR2/eclipse-jee-indigo-SR2-win32.zip 

Java runtime environment (JRE) 

Version 1.6.0_29 or 1.6.0_30 
(Version 7 should be removed from your PC.) 

[1.6.0_29]  
http://www.oracle.com/technetwork/java/javaseb
usiness/downloads/java-archive-downloads-
javase6-419409.html#jre-6u29-oth-JPR 

[1.6.0_30]  
http://www.oracle.com/technetwork/java/javaseb

usiness/downloads/java-archive-downloads-

javase6-419409.html#jre-6u30-oth-JPR 

 

https://www.virtualbox.org/wiki/Download_Old_Builds
https://www.virtualbox.org/wiki/Download_Old_Builds
http://support.apple.com/kb/DL1531
http://www.microsoft.com/en-us/download/details.aspx?id=8109
http://www.microsoft.com/en-us/download/details.aspx?id=8109
http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/indigo/SR2/eclipse-jee-indigo-SR2-win32.zip
http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/indigo/SR2/eclipse-jee-indigo-SR2-win32.zip
http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/indigo/SR2/eclipse-jee-indigo-SR2-win32.zip
http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-archive-downloads-javase6-419409.html#jre-6u29-oth-JPR
http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-archive-downloads-javase6-419409.html#jre-6u29-oth-JPR
http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-archive-downloads-javase6-419409.html#jre-6u29-oth-JPR
http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-archive-downloads-javase6-419409.html#jre-6u30-oth-JPR
http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-archive-downloads-javase6-419409.html#jre-6u30-oth-JPR
http://www.oracle.com/technetwork/java/javasebusiness/downloads/java-archive-downloads-javase6-419409.html#jre-6u30-oth-JPR
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Installation Guide (for Windows) 

This section introduces how to install the LG Smart TV SDK on Windows PC. 
 
 Installing the VirtualBox 
 Installing the Web Browser (Safari) 
 Installing the LG Smart TV SDK 
 Uninstalling the LG Smart TV SDK 

 

Installing the VirtualBox 

This section is only required for developers who want to use LG Smart TV Emulator 2012 or 2013. 

 

Note 

To use LG Smart TV Emulator 2012 or 2013, you must install the Oracle VirtualBox first on your computer 
before installing the LG Smart TV SDK. 

 
If you want to use only LG Smart TV Emulator 2011, you can skip this section. 

 
1. Go to http://www.oracle.com/technetwork/server-storage/virtualbox/downloads/index.html. Download the 

proper VirtualBox execution file. 
 

 
 

2. Double click on VirtualBox execution file. VirtualBox installation wizard will be launched. Click [Next]. 

 
3. Click [Next] to install VirtualBox with default settings. To change the installation path, click [Browse] and choose 

the folder. 
 
4. In creating shortcuts window, click [Next]. 

 
5. Network Interface warning window appears. Click [Yes]. Network is temporarily disconnected from your computer 

during installing Oracle VirtualBox.  
 

http://www.oracle.com/technetwork/server-storage/virtualbox/downloads/index.html
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6. Click [Install] to proceed.  

 
7. Installation starts. 
 
8. In compatible with Windows Logo Testing window, click [Continue Anyway] to proceed. 

 

 
 
9. Click [Finish]. Installation completes. 

 

Installing the Web Browser (Safari) 

To use WYSIWYG Preview and Web Application Framework, you must install webkit libraries. Web browser will be 
installed automatically during installing the LG Smart TV SDK. 
 
1. In Welcome window, click [Next] to install the web browser. 

 
2. The license agreement window appears. Select [I agree the terms in the License Agreement] and click [Next]. 

 
3. Installation Options window appears. Click [Next]. 

 
4. Click [Next] to install the web browser with default settings. To change the installation path, click [Change] and 

choose the folder. 
 
5. Installation starts. 
 
6. Click [Finish]. Installation completes. 
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Installing the LG Smart TV SDK 

The following steps describe how to install the LG Smart TV SDK. 
 

Note 

To use LG Smart TV Emulator 2012 or 2013, you must install the Oracle VirtualBox first from 
http://www.oracle.com/technetwork/server-storage/virtualbox/downloads/index.html on your computer before 
installing the LG Smart TV SDK. For details, refer to Installing the VirtualBox. 

 
If the Oracle VirtualBox and Safari are not installed on your computer, installer automatically installs the Oracle 
VirtualBox and Safari at the end of the installation step. But the network must be connected on your computer and the 
system may be slow during installation. If the network is not connected, the Oracle VirtualBox cannot be installed. 
 
Before you install the new LG Smart TV SDK version, uninstall the previous version of LG Smart TV SDK 
using the uninstaller. For how to uninstall the LG Smart TV SDK, please refer to Uninstalling the LG Smart TV 
SDK. 

 
1. Run the LG Smart TV SDK Installer. 
 

 
 
2. The LG Smart TV SDK installation wizard is launched. Click [Next]. 

 
3. The license agreement window appears. Select [I agree the terms of the License Agreement] and click [Next]. 

 
4. Click [Next] to install the LG Smart TV SDK with default settings. To change the installation path, click [Choose] 

and select the folder. 
 
5. Pre-Installation summary window appears. Click [Install] to proceed. 

You can check the installation summary such as product name, install folder and so on. 
 
6. Installation starts. 
 

Note 

We recommend you to install the VirtualBox and Safari before installing the LG Smart TV SDK. But if you could not 
install the VirtualBox and Safari in advance, the LG Smart TV SDK Installer downloads VirtualBox application from 
VirtualBox online repository at the end of the step 6 if your computer is connected to the network, and runs 
downloaded VirtualBox application automatically. 
 
But if your computer is disconnected from the network, the following window appears. Click [OK] button to cancel the 
installation of LG Smart TV SDK. In this case, you should install the Oracle VirtualBox manually referring to Installing 
the VirtualBox then, install the LG Smart TV SDK again. 

 

http://www.oracle.com/technetwork/server-storage/virtualbox/downloads/index.html
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7. The Oracle VirtualBox installation wizard is launched. For more details, refer to Installing the VirtualBox. 

 
8. After installing VirtualBox, Web Browser (Safari) installation wizard is launched. For more details, refer to Installing 
the Web Browser (Safari). 

 
9. Click [Done]. Installation completes. 

 

Caution 

If the previous version of LG Smart TV SDK has not been uninstalled or the previous installation directory of LG 
Smart TV SDK has been manually deleted, the following popup appears during installing the new LG Smart TV SDK. 
 

 
 
Follow the next step to solve the problem. 
 
Case 1> If the previous version of LG Smart TV SDK has not been uninstalled, click [OK] button in popup window. 

Then, the previous LG Smart TV SDK is automatically uninstalled. 
 
Case 2> If the previous installation directory of LG Smart TV SDK has been manually deleted, un-installation of the 

previous LG Smart TV SDK cannot proceed and error message pops up as below. 
 

.  
 
Click [OK] to close the installer. Then delete the following hidden file manually. 

C:\Program Files\Zero G Registry\.com.zerog.registry.xml 
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Uninstalling the LG Smart TV SDK 

The following steps describe how to uninstall the LG Smart TV SDK.  
 
1. Select [LG Smart TV SDK > Uninstall] from the Start menu. 

 

 
 
2. The InstallShield wizard starts. Click [Next]. 

 

 
 
3. Click [Next] to uninstall the LG Smart TV SDK. 

 
4. All the features of application are being removed. 
 
5. Uninstallation is completed. Click [Done]. 
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Installation Guide (for Linux) 

This section introduces how to install the LG Smart TV SDK on Linux PC. 
 
 Installing the VirtualBox 
 Installing the LG Smart TV SDK 
 Starting the LG Smart TV SDK 
 Uninstalling the LG Smart TV SDK 

 

Installing the VirtualBox 

This section is only required for developers who want to use LG Smart TV Emulator 2012 or 2013. 

 

Note 

To use LG Smart TV Emulator 2012 or 2013, you must install Oracle VirtualBox first on your PC before 
installing the LG Smart TV SDK. 
 

LG Smart TV Emulator 2011 is not supported in Linux. And only admin account can install and uninstall the LG 
Smart TV SDK. 

 
1. Go to http://www.oracle.com/technetwork/server-storage/virtualbox/downloads/index.html. Download the 

proper VirtualBox execution file. 
 

http://www.oracle.com/technetwork/server-storage/virtualbox/downloads/index.html
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2. Install the VirtualBox with Ubuntu Software Center. 
 

 
 
3. Click [Install] to install VirtualBox with default settings. 

 

Installing the LG Smart TV SDK 

The following steps describe how to install the LG Smart TV SDK. 
 
You can download “rar” files for installation from the LG Developer (http://developer.lge.com) website. In Ubuntu 

case, downloaded files are placed in the “Downloads” folder.  
 
To install the LG Smart TV SDK, you must decompress downloaded “rar” files using a compression application such 
as “7zip” and “RAR”. 
 

Note 

http://developer.lge.com/
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To use LG Smart TV Emulator 2012 or 2013, you must install the Oracle VirtualBox first from 
http://www.oracle.com/technetwork/server-storage/virtualbox/downloads/index.html on your computer before 
installing the LG Smart TV SDK. For details, refer to Installing the VirtualBox. 

 
If the Oracle VirtualBox and Safari are not installed on your computer, installer automatically installs the Oracle 
VirtualBox and Safari at the end of the installation step. But the network must be connected on your computer and the 
system may be slow during installation. If the network is not connected, the Oracle VirtualBox cannot be installed. 
 
Before you install the new LG Smart TV SDK version, uninstall the previous version of LG Smart TV SDK 
using the uninstaller. For how to uninstall the LG Smart TV SDK, please refer to Uninstalling the LG Smart TV 
SDK. 

 
You can install the LG Smart TV SDK as root account in terminal. 

 
1. Go to the downloaded folder in terminal and change the permission of extracted installation package. 
 

$ CD [downloaded folder] 

$ chmod +x LG_Smart_TV_SDK_Installer.bin 

 
2. Run the SDK installation package using ‘sudo’ command in terminal. You must have a rights as root account. 
 

$ sudo ./LG_Smart_TV_SDK_Installer.bin 

 

 
 

Caution 

You have to run the LG Smart TV installer or uninstaller as root account. If not, following message appears.  
 

 
 
Please use ‘sudo’ command to get a rights as root account when you run installer and uninstaller. 

 
3. Introduction Step : Review the introduction of the LG Smart TV SDK Installation. Click [Next]. 

 

NOTE 

We recommend you to install the VirtualBox and Safari before installing the LG Smart TV SDK. But if you could not 
install the VirtualBox and Safari in advance, the LG Smart TV SDK Installer downloads VirtualBox application from 

http://www.oracle.com/technetwork/server-storage/virtualbox/downloads/index.html
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VirtualBox online repository at the end of the step 3 if your computer is connected to the network, and runs 
downloaded VirtualBox application automatically. 
 
But if your computer is disconnected from the network, the following window appears. Click [OK] button to cancel the 
installation of LG Smart TV SDK. In this case, you should install the Oracle VirtualBox manually referring to Installing 
the VirtualBox then, install the LG Smart TV SDK again. 

 

 

 
4. License Agreement Step : To continue the installation, review the License Agreement and select the “I accept the 
terms of the License Agreement” option. Click [Next]. 

 
5. Choose Install Folder Step : To change the installation path, click [Choose…] and select the folder. If you want to 
install to default folder, click [Next].  

 
6. Pre-Installation Summary Step : Review installation information(Product Name, Install Folder, Link Folder, Disk 
Space Information) before continuing. Click [Install] to proceed. 

 
7. Installation starts. 
 
8. Run the script as shown in the warning message to install the webkit program in terminal. 
 

$ sudo apt-get install libwebkitgtk-1.0-0 

$ sudo apt-get install libwebkitgtk-1.0-common 

 

 
 

Note 

You must install the webkit libraries to use WYSIWYG Preview and Web Application Framework. 

 
9. Installation completes. Click [Done] to finish the LG Smart TV SDK installation. 

 

Caution 

If the previous version of LG Smart TV SDK has not been uninstalled or the previous installation directory of LG 
Smart TV SDK has been manually deleted, the “Manage Instances” popup appears during installing the new LG 
Smart TV SDK. 
 
Follow the next step to solve the problem. 
 
Case 1> If the previous version of LG Smart TV SDK has not been uninstalled, click [OK] button in popup window. 

Then, the previous LG Smart TV SDK is automatically uninstalled. 
 



 

 |  20 

Case 2> If the previous installation directory of LG Smart TV SDK has been manually deleted, un-installation of the 

previous LG Smart TV SDK cannot proceed and error message pops up as below. 
 

 
 
Click [OK] to close the installer. Then delete the following hidden file manually. 

$HOME\.com.zerog.registry.xml 

 

Starting the LG Smart TV SDK 

You need to execute the LG IDE and LG Smart TV Emulator 2012 or 2013 by clicking the shortcut of Dash Home.  
In Dash Home, search by keyword “LG” to find LG IDE and LG Smart TV Emulator 2012 or 2013. 
 

 
 

Caution 

If you use terminal to execute IDE and Emulator under the [LG Smart TV SDK] folder, they do not work normally. 
You must execute them by shortcut of Dash Home. 

 

Uninstalling the LG Smart TV SDK 

The following steps describe how to uninstall the LG Smart TV SDK. You can un-install the LG Smart TV SDK as root 
account in terminal. 
 
1. Go to the Uninstaller folder in terminal. 
 

$ CD [Path of the Uninstaller folder] 

 
2. Run the SDK Uninstaller using ‘sudo’ command in terminal. You must have a rights as root account. 
 

$ sudo ./UnInstaller 
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3. To uninstall the LG Smart TV SDK, Click [Next]. 

 

 
 
4. Review uninstallation information. Click [Next] to uninstall. 

 
5. Uninstallation starts. 
 
6. Click [Done]. Uninstallation completes. 
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Installation Guide (for Mac) 

This section introduces how to install the LG Smart TV SDK on Mac PC. 
 
 Installing the VirtualBox 
 Installing the LG Smart TV SDK 
 Starting the LG Smart TV SDK 
 Uninstalling the LG Smart TV SDK 

 

Installing the VirtualBox 

This section is only required for developers who want to use LG Smart TV Emulator 2012 or 2013. 

 

Note 

To use LG Smart TV Emulator 2012 or 2013, you must install Oracle VirtualBox first on your PC before 
installing the LG Smart TV SDK. 
 

LG Smart TV Emulator 2011 and Flash are not supported in Mac. And only admin account can install and uninstall 
the LG Smart TV SDK. 

 
1. Go to http://www.oracle.com/technetwork/server-storage/virtualbox/downloads/index.html. Download the 

proper VirtualBox execution file. 
 

http://www.oracle.com/technetwork/server-storage/virtualbox/downloads/index.html
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2. To Install the VirtualBox on Mac, double click the VirtualBox.mpkg icon. 
 

 
 

Installing the LG Smart TV SDK 

The following steps describe how to install the LG Smart TV SDK. 
 
You can download “rar” files for installation from the LG Developer (http://developer.lge.com) website. In Mac OS 

case, downloaded files are placed in the “Downloads” folder. 
 
To install the LG Smart TV SDK, you must decompress downloaded “rar” files using a compression application such 
as “The Unarchiver”. 
 

http://developer.lge.com/
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NOTE 

To use LG Smart TV Emulator 2012 or 2013, you must install the Oracle VirtualBox first from 
http://www.oracle.com/technetwork/server-storage/virtualbox/downloads/index.html on your computer before 
installing the LG Smart TV SDK. For details, refer to Installing the VirtualBox. 

 
If the Oracle VirtualBox and Safari are not installed on your computer, installer automatically installs the Oracle 
VirtualBox and Safari at the end of the installation step. But the network must be connected on your computer and the 
system may be slow during installation. If the network is not connected, the Oracle VirtualBox cannot be installed. 
 
Before you install the new LG Smart TV SDK version, uninstall the previous version of LG Smart TV SDK 
using the uninstaller. For how to uninstall the LG Smart TV SDK, please refer to Uninstalling the LG Smart TV 
SDK. 

 
You can install the LG Smart TV SDK using terminal. 

 
1. Go to the downloaded folder in terminal and change the permission of extracted installation package. 
 

$ CD [downloaded folder] 

$ chmod –R +x LG_Smart_TV_SDK_Installer.app 

 
2. Run the SDK installation package using ‘open’ command in terminal. 
 

$ open LG_Smart_TV_SDK_Installer.app 

 

 
 

Note 

If the following popup appears, check your security setting at System Preferences. 
 

http://www.oracle.com/technetwork/server-storage/virtualbox/downloads/index.html
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Move to “Applications > System Preferences > Security & Privacy > General Tab”. Change “Allow applications 
downloaded from:” to “Anywhere”. 
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If you do not change your security & privacy setting, you can’t open extracted LG Smart TV SDK package. 

 
3. When installation starts, warning window appears as following figure. Press [Open] to continue installation. 

 

 
 
4. Authentication : Type your administrator name and password for authentication. Click [OK]. 
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5. Introduction Step : Review the introduction of the LG Smart TV SDK Installation. Click [Next]. 

 
6. License Agreement Step : To continue the installation, review the License Agreement and select the “I accept the 
terms of the License Agreement” option. Click [Next]. 

 
7. Choose Install Folder Step : In Mac OS, you can’t change install folder. The installer skips this step. 
 
8. Pre-Installation Summary Step : Review installation information(Product Name, Install Folder, Link Folder, Disk 
Space Information) before continuing. Click [Install] to proceed. 

 
9. Installation starts. 
 

Note 

We recommend you to install the VirtualBox and Safari before installing the LG Smart TV SDK. But if you could not 
install the VirtualBox and Safari in advance, the LG Smart TV SDK Installer downloads VirtualBox application from 
VirtualBox online repository at the end of the step 3 if your computer is connected to the network, and runs 
downloaded VirtualBox application automatically. 
 
But if your computer is disconnected from the network, the following window appears. Click [OK] button to cancel the 
installation of LG Smart TV SDK. In this case, you should install the Oracle VirtualBox manually referring to Installing 
the VirtualBox then, install the LG Smart TV SDK again. 

 

 

 
10. Installation completes. Click [Done] to finish the LG Smart TV SDK installation. 

 

Caution 

If the previous version of LG Smart TV SDK has not been uninstalled or the previous installation directory of LG 
Smart TV SDK has been deleted manually, the “Manage Instances” popup appears during installing the new version 
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of LG Smart TV SDK. 
 
Follow the next step to solve the problem. 
 
Case 1> If the previous version of LG Smart TV SDK has not been uninstalled, click [OK] button in popup window. 

Then, the previous LG Smart TV SDK is automatically uninstalled. 
 
Case 2> If the previous installation directory of LG Smart TV SDK has been manually deleted, un-installation of the 

previous LG Smart TV SDK cannot proceed and error message pops up as below. 
 

 
 
Click [OK] to close the installer. Then delete the following hidden file manually. 

\library\preferences\.com.zerog.registry.xml 

 

Starting the LG Smart TV SDK 

You need to execute the LG IDE and LG Smart TV Emulator 2012 or 2013 by clicking each icon in the Applications 
folder as following.  
 

 
 

Caution 

If you use terminal to execute IDE and Emulator under the [LG Smart TV SDK] folder, they do not work normally. 
You must execute them by clicking each icon in the Application folder. 

 

Uninstalling the LG Smart TV SDK 

The following steps describe how to uninstall the LG Smart TV SDK. 
 
1. Go to the Uninstaller folder in terminal. 
 

$ CD /opt/LG_Smart_TV_SDK/UnInstaller 

 
2. Run the SDK Uninstaller using ‘open’ command in terminal. 
 

$ open UnInstaller.app 
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3. To uninstall the LG Smart TV SDK, Click [Next]. 

 

 
 
4. Review uninstallation information. Click [Next] to uninstall. 

 
5. Uninstallation starts. 
 
6. Click [Done]. Uninstallation completes. 

 

 
 

LG IDE Plugin Installation Guide 

This section introduces how to install the LG IDE Plugin. 
 
 Installing the LG IDE Plugin 
 Uninstalling the LG IDE Plugin 

 
LG IDE plugin lets web developers use Eclipse to develop web applications for LG Smart TV. By installing this plugin, 
developers can create web applications for LG Smart TV but with limitation. LG IDE Plugin provides the almost same 
features as the LG IDE provides except as follows: 
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- API Validation checker 
- Construction of Menu bar, Toolbar and Context menu 
- Default editors provided depending on the file types 
- Setting the file format to UTF-8 when encoding/decoding 
- Import menu for W3C Widget Package 
- Group icon of “New” and “Search” on Toolbar 
- Zoom in/out in WYSIWYG design page 
 

Installing the LG IDE Plugin 

To install the LG IDE plugin for web application development in Eclipse Java EE, follow the next steps. Eclipse Java 
EE includes the existing Eclipse WTP extended version, web development, web services, DB, etc. 
 

Caution 

After installing the LG IDE Plugin in Mac OS, you MUST COPY the 
“org.eclipse.wst.server.preview.adapter_1.1.0.v20090311b.jar” file from opt\LG_Smart_TV_SDK\Resources > 
Libraries\jarformac folder manually into the plugins folder in eclipse. 

 
1. In Java EE Eclipse, click [Help > Install New Software]. 

 

 
 
2. Following dialog appears. Click [Add] button. 
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3. Following [Add Repository] dialog appears. 
 

 
 
Click [Archive] to set the location where you have your LG IDE plugin. 

 
4. In the following dialog, click “LGPlugin.zip” and [Open]. 
 

 
 
Plugin file path is: Boot drive\Program Files\LG_Smart_TV_SDK\LGPlugin\LGPlugin.zip.  
 
The location is set as follows.  
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Click [OK]. 

 

Note 

If the following warning appears, click [Cancel] button to close the window. 

 

 
 
Choose the existing location where LG Smart TV SDK has been installed before from the “Work with” combo box. 
 

 
 
The “Work with” will be set with the existing location. 
 

 
 
Then, follow the next steps. 

 
5. As below, “Work with” is set with the assigned path. 
Select “Select All” and check “Contact all update sites during install to find required software”. 
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Click [Next]. 

 
6. System is now calculating the requirements and dependencies. 
 

 
 
7. After the calculation, the detailed installation items are displayed. 
Click [Next]. 
 

8. License agreement screen appears. 
Check [I accept the terms of the license agreement] and click [Finish].  
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9. The software is installed now. 
 

 
 
10. During the installation, the following warning message may appear. 
 

 
 
Click [OK]. 

 
11. Click [Restart Now] to installation take effect. 

 

 
 
Then, Eclipse restarts automatically. 
 
 

Uninstalling the LG IDE Plugin 

The following steps describes how to uninstall LG IDE plugin for web application development. 
 
1. Start the Eclipse and go to [Help > Install New Software] and there you will find a hyperlink named “already 

installed”. 
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2. By clicking on the hyperlink, the following window will open as below. 
Under the [Installed Software] tab, select each and click on [Uninstall].  

 

 
 
3. Click [Finish] in the following window. 
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4. Click [Restart Now] to uninstallation take effect. 

 

 
 
To delete entire plugin, follow the next steps. 
Go to [Help > Install New Software] and select [already installed?] and click [Installation History] tab. 

 

 
 
Now you will get a current installation list and a few time-based list. Check all the lists available and wherever you get 
an item named with LG, select all of them and click [Delete] and then restart Eclipse. 

 
By applying this approach, you can clean up the entire plugin including roots available and then install any other 
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same LG plugin properly. 
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Creating the Project 

Once the LG Smart TV SDK is installed on your PC, start the LG IDE.  

To start the SDK in Windows, click [LG Smart TV SDK > LG IDE] from the Start menu or the icon  from the 
desktop screen. To start the SDK in Linux or Mac, see Starting the SDK (for Linux) or Starting the SDK (for Mac). 

 
Then, you can create a project in the following ways. 
 
 Creating Web Page from a Blank Web Project 
 Creating Web Page from LG Web Page Template 
 Creating Web Page from LG Web Page Designer 
 Importing Custom Template 
 Importing Existing Widget Package 
 Importing Sample Codes 
 Importing Existing Project  

 

Note 

Multiple users can use the same SDK with different accounts in Linux and Mac OS since LG Smart TV SDK V2.2.1. 
Only administrator has rights to install and uninstall the LG Smart TV SDK in supported OS. And all users can use 
the LG Smart TV SDK without any permission in Linux and Mac OS. 

 

Creating Web Page from a Blank Web Project 

1. In IDE, click [File > New > LG Web Project]. 

 
2. Give a project name and select ‘SDK Version for Web Application’. Then, click [Finish]. 

 

Note 

You can change the SDK version for the project in [Properties] window later. Refer to the section Setting SDK 
Version of the Project.  
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Creating Web Page from LG Web Page Template 

LG IDE provides various UI templates that allow you to easily develop LG web applications. 
 
These templates are web page layouts using UI components which comply with LG UI Guidelines. A variety of 
templates per type is available. The template used in this document provides many types of layouts; the UI 
components created will not work in a browser. You need to modify source code and attributes in order to make them 
work. 
 
The following shows how to import LG template into my project. 
 
1. In IDE, select the ‘WebContent’ folder from Project Explorer in your project and click [New > LG Web Page 
Template] from the right-click menu. 

 
2. The ‘LG Web Page Template’ window appears as shown below. Types are displayed on the left and various 
templates per type are on the right. You can specify a target folder to which a template file is copied and its name. 
Select a template and click [Finish] to create a template folder in the currently opened project. 
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3. The ‘Books_Magazine_2_Color1’ folder is created in the project and project files such as html, js, css, image are 
copied as shown below. To modify the web page, refer to the section Using LG WYSIWYG Editor. 

 

 
 

Creating Web Page from LG Web Page Designer 

To develop web application quickly, you can use the LG Web Page Designer.  
Using the LG Web Page Designer, you can implement your application easily by adding Web UI components to 
designer editor. 
 
Designer(WYSIWYG) Editor supports the following features. 
- Drag and drop the Web UI components 
- Adjust the component size and position 
- Zoom in/out the components 
- Show the safety zone in 1280 * 720 pixel as same as emulator and real TV. 
 
The following shows how to create the web application using LG Web Page Designer. 
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1. Click [File > New > LG Web Page Designer] from the menu. 
Or click [New > LG Web Page Designer] from the right-click menu in Project Explorer. 

 

 
 
2. The ‘LG Web Page Designer’ window appears as shown below.  
You can select a target project to which a new designer file is created.  
 

 
 
3. Click [Finish] to create a new designer file(.lge) in the selected project. 

 
4. The .lge file is created under ‘WebContent’ folder and source code for html, css and js is automatically generated in 
each folder under the ‘WebContent’. All resource files have the same name as the .lge file. 
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And a new designer editor is open as below. 
 

 
 
5. Add any Web UI components into the designer editor and resize the component within safety zone(red square line) 
as below.  
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6. The preview is displayed in the WYSIWYG preview window. And if any component is positioned out of safety zone, 
the outlines shows as below. 
 

 
 

Note 

For Windows OS, you should click toolbar icon  to check the preview. Then the external web browser pops up and 
shows the preview as below. 
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7. To edit the source code, open .html file.  
 

Caution 

We recommend you to edit .html file after adding all Web UI components. The changes in .html file are not 
automatically updated into the .lge file. 

 
8. Edit .css and .js files if necessary. 
 

Importing Custom Template 

LG IDE provides various UI templates for you to easily develop LG web applications. But you want to use your own 
template for web application development.  
 
The following shows how to add a new custom template. 
 
1. In IDE, click [File > New > LG Web Page Template]. 

 
2. The ‘LG Web Page Template’ window appears as shown below. Click ‘New Template’ Select a template and click 
[Finish] to create a template folder in the currently opened project. 

 

 
 
3.Enter the information of the template you want to add in the ‘Add New Template’ window. Each field is described 
below:  
 
• Template Name: Template name 
• Template Resource Location: Directory including template resources (index.html, thumbnail.png, js and css files) 
 

 
 

Note 

To add a custom template, all resource files such as index.html, thumbnail.png, .js and .css must be saved in the 
same template folder. 



 

 |  45 

 

Importing Existing Widget Package 

1. In IDE, select [File > Import] and select ‘W3C Widget Package > W3C Widget Package'. Then, click [Next]. 

 

 
 
2. Load the existing widget (.wgt), which has the W3C widget packaging format. (Refer to 
http://www.w3.org/TR/widgets/) Click [Browse] and select the widget file stored in your PC.  

 

 
 
3. Click [Finish].  

 
4. Now create a new project where to import the selected widget. Give a project name and select ‘SDK Version for 
Web Application’. Then, click [Finish]. 

 

http://www.w3.org/TR/widgets/
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Importing Sample Codes 

LG provides several web application samples. In LG Developer (http://developer.lge.com) website, go to 
[DISCOVER > Legacy Platform (NetCast) > Tools & Samples] menu and download the sample codes on your PC. 

 
1. In IDE, create a blank project and select ‘WebContent’ folder from Project Explorer. 
 
2. Select [Import] from right-click menu, then, select ‘General > Archive File' and click [Next]. 

 

 
 
3. In the following window, click [Browse] to choose the sample codes file. Be sure to check on ‘Overwrite existing 

resources without warning’. 
 

http://developer.lge.com/
http://webostv.developer.lge.com/discover/netcast/tools-samples/
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4. Select the sample codes file (.zip) from file dialog and click [Open]. 

 
5. Click [Finish]. Then, the sample codes will be imported into your project. 

 

 
 

Importing Existing Project 

From LG Smart TV SDK V2.2, LG IDE is newly provided for web application development. If the project was created 
earlier than SDK V2.2, and SDK V2.2 or higher version is installed on your PC, you must import the existing project 
on LG IDE. 
 
1. In IDE, create a blank project and select ‘WebContent’ folder from Project Explorer. 
 
2. Select [Import] from right-click menu, then, select ‘General > Archive File' and click [Next]. 
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3. In the following window, click [Browse] to select the existing project source files (.zip) from file dialog and click 
[Open]. 

 

 
 
4. Click [Browse] to import the selected project into a folder and click [OK]. Be sure to check on ‘Overwrite existing 

resources without warning’. 
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5. Click [Finish]. Then, the existing project source files will be imported into your project. 
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Using LG WYSIWYG Editor 

The WYSIWYG Editor allows developers to easily use and edit LG Web UI components in LG IDE. It can be activated 
by double-clicking on an HTML from the Project Explorer.  
 
The following describes how to edit HTML page using the WYSIWYG Editor. 
 

 
 

(1) [Palette] contains LG Web UI components. (If you cannot see the [Palette], click on .) 
Select a component from [Palette] and drag-and-drop it to the certain location of web page. 
 

 
 
(2), (3) When you select a component in the web page, an HTML tag of the component is also selected at the bottom. 
To make components work, make changes in the JavaScript source code or set attributes from the Properties tab at 
the right pane. 
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(4) Alert the problems on API, JavaScript source code.  
 
For guidelines on how to use components, refer to Developing > API > Web UI Component API section in this 

Library. 
 
Refer to the “UI Guidelines” in Developing > Designing section in this Developer Library. 

 

Note 

Created UI components should be operated by not only using mouse pointer but also Arrow keys and OK key. 
Developers must implement the codes for key operations. 

 
 

Importing Custom Components 

In addition to LG components, you can add custom components to Palette of the WYSIWYG Editor. For example, 
jQuery components can be imported into the project. 
 
1. To add the custom components, click LG Custom Component under [Palette]. 

2. When the Custom Components window appears, click . 
 

 
 
3. Enter the information of the component you want to add in the Custom Component window. Each field is described 
below:  
(This is an example using Image Slider http://dev7studios.com/portfolio/nivo-slider/) 

 
• Name: Component name 
• Description: Description on the component 
• Component Path: Directory including custom component resources (js, css, image files) 
• CSS/JS files: Code block including css and js file. It is inserted in the HEAD section 
• Script code: JavaScript code block initializing the component. It is created as an external JavaScript (.js) file 
• HTML code: HTML code block about component HTML tag. It is inserted in the BODY section 

 

http://dev7studios.com/portfolio/nivo-slider/
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When finished, click [OK]. 

 
4. You can check whether the custom component is added to the Custom Components category under Palette. Drag-
and-drop an item to the location you want in the project. 
 
5. Open the Custom Components window to delete, edit, and reorder components.  

: Deletes the selected component from the list. 

: Reorders the components in the list. 

 : Edits the component information. 

 : Opens the browser window to preview the components. 
 

 
 
When finished, click [Close]. 
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WYSIWYG Preview 

From LG Smart TV SDK V2.4, WYSIWYG preview is supported in the WYSIWYG Editor for Linux and Mac. This 
enables you to check the preview of an application before launching at emulator or Real TV.  
 
WYSIWYG Preview supports GMF Editor (*.lge) and Page Editor (*.html). So if you work with .lge file or .html file, you 
can check the view without executing application on the emulator or TV.  
 
Select .lge file or .html file in Project Explorer then, you can check the WYSIWYG preview at once. 
 

Note 

For only Windows OS, preview is launched in external web browser. To execute the preview on Windows, 
select .lge file or .html file in Project Explore and click [WYSIWYG Preview] from the right-click menu or toolbar icon 

. Then external web browser will launch to show the preview. 

 

Caution 

To execute the preview on Windows OS, safari (web browser) must be installed on your computer. 
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Utilities 

LG IDE provides the following utilities: 
 

• Setting SDK Version of the Project 

• API Validation Checker 

• LG Image Viewer 

• JSON Editor 

• Changing the Perspective 

• Checking the Server 

• LG Start Page 

 

Setting SDK Version of the Project 

The SDK version can be set up on each step - initial, intermediate, and final packaging stages. Therefore, the project 
will properly complied with SDK version, such as Configuration Tool. To change the SDK version for web application, 
follow the next steps.  
 
1. In IDE, select the project from Project Explorer and click [Properties] from the right-click menu. 

 
2. In the following window, click LG SDK Version’ from the left pane. 
 
3. Select SDK Version for web application and click [Apply]. 

 

 
 
4. Click [OK]. 

 

Note 

LG SDK Version shows only the initial version and the latest version of the SDK. As the selected SDK version, API 
library will be updated. 

 
 

API Validation Checker 

LG IDE provides the following functions for JavaScript developing as well as HTML and CSS. Because these 
functions depends on the SDK version of the project, you must first check the SDK version for web application in the 
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Properties menu.  
 
 Auto Completion 
 Sensitive Help 
 Syntax Error Checker 
 JSLint & CSSLint 

 

Auto Completion 

After creating a JavaScript file, use the auto-completion function in the following way.  
For example, type ‘window.’ and the press [Ctrl+ Space], then, related APIs will appear. 

 

 
 

Sensitive Help 

In JavaScript source code, move the mouse curser onto a method or property to see the sensitive help popup. 
 

 
 

Syntax Error Checker 

If there are syntax errors and warnings, the IDE will show red and yellow icons on the source codes as below. 
Move the mouse cursor onto the red or yellow icon, then, the error or warning message appears. 
 

 
 
All errors and warnings can be checked categorized by API Problems, Fatal Errors, Potential Programming Problems 
and so on in [Problems] tab. 
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The red and yellow icons means that red icon ( ) includes errors and warning and yellow icon ( ) includes 
warnings only. 
 
If you do not want to use Validation checker function, click [Window > Preferences] from the menu. Then select 
[JavaScript > Validator > Error/Warnings] from the left pane and set the resolution as ‘Ignore’.  

 
 

 
 

JSLint & CSSLint 

The LG IDE provides the function to check the syntax in source code of HTML, JavaScript, and CSS. This function 
can be used manually or automatically. 
 
To check the syntax manually, select a .js file or .css file from Project Explorer and click [JSLint] or [CSSLint] from 

the right-click menu. All checked syntax errors are shown in [Markers] tab. 
 

 
 
If you want to check the syntax every build time or not, change the setup by clicking [Window > Preferences] from 
the menu. In the following window, select [JavaScript > Editor > JS Lint Setting] or [Web > CSS Files > CSS 
Editor] from the left pane.  
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Also select [Web > HTML Files > Validation] from the left pane to change the setting of HTML. To avoid some errors 

on video tag and Web UI component attributes, LG IDE sets some fields related to HTML to ‘ignore’ by default. 
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Note 

Because of the performance down problem, we do not recommend to declare any variable in for statement. If you 
want to filter variables out in for statement, check ‘Disallow var declarations in for statement’ checkbox in JSLint 
options. Then, the variables declared in for statement are checked to ‘error’. 

 
To apply the setting, click [Apply]. 

 

LG Image Viewer 

LG Image Viewer is a feature to view images in LG IDE. Supported image formats are BMP, GIF, PNG, and JPG. To 
launch in LG IDE, user has to put image files in project folder. 
 
1. In project explorer, click on a folder that includes image files. 
 
2. Then, the image list is shown with thumbnail images in [LG Image Viewer] pane. If you click on a image thumbnail, 
the [LG PREVIEW] pane will display the image. 
 

 
 

JSON Editor 

If you have a JSON file in your project, you can edit it with JSON Editor in LG IDE. 
 
1. In IDE, open the .json file and click [Open With > JSON Editor] from the right-click menu. 
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2. Then, the JSON Editor is opened. 
 

 
 

3. To add a key, press  button, then, a key row will be added.  
 

 
 
4. Set key name, value, and type by clicking on each field. Added keys are displayed in left tree. 
 

 
 

5. To delete a key, select the key to delete and press  button. 
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6. You can change the order of keys using the following arrow icons . 
 

 
 
 

Changing the Perspective 

You can change the perspective of LG IDE if you want by clicking on the toolbar tab as below. 
 

 
 
 WYSIWYG: Application developing mode 
 Remote Debug: Debugging mode using Web Inspector (on LG Smart TV Emulator 2012/2013, Real TV) 
 Local Debug: Debugging mode (on LG Smart TV Emulator 2011) 
 

Checking the Server 

To run a web application on the emulator, the web server should be started in the LG IDE first. The web server is 
automatically started from LG Smart TV SDK V2.2.0. 
 
You can start/stop/restart the web server manually by clicking the buttons or from the right-click menu on [Servers] 

tab. 
 



 

 |  61 

 
 

Note 

If you can’t find the [Servers] tab, click [Window > Show View > Others]. Select ‘Server > Servers’ from the list in 
the popup and click [OK]. 

 
The project can be configured as a different server as below and start its own server. 
 

 
 
But if the server is not started when executing the project, the IDE checks whether any server is started now and add 
the project into the server. 
 

 
 
 

LG Start Page 

The LG Start Page includes helpful links for developers.  
 
1. Click [Help > Welcome to LG Start Page].  
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2. LG Start Page screen appears. 
 

 
 
If any page is not open in the editor, LG Start Page is displayed in the editor whenever LG IDE is open. 
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Troubleshooting 

Q1) The “SDK Directory Path cannot be read” error message is shown when executing the LG IDE. 

 

 
 
Q2) The “Cannot find lgsetup.xml" error message is shown when creating a new project in the LG IDE. 

 

 
 
A1, A2) If you deleted the previous LG Smart TV SDK folder manually instead of uninstallation and installed the new 
LG Smart TV SDK on the same PC, this message may be occured because incorrect environment variables are set 
to LG_SDK_HOME and LG_SDK_PROPERTIES. 
 
Please check the environment variables and change the LG_SDK_HOME and LG_SDK_PROPERTIES to the actual 
installation path of LG Smart TV SDK. 
 
If this error message pops up continuously despite the above mentioned, follow the next steps. 
1. Delete LG_SDK_HOME and LG_SDK_PROPERTIES from the environment variables. 
2. Delete ‘C:\Program Files\Zero G Registry’ folder. (This folder may be hidden) 
3. Delete LG Smart TV SDK folder where the old SDK is installed. 
4. Install the LG Smart TV SDK again. 
 
 
Q3) When I open the eclipse after installing the LG IDE Plugin in Mac OS, the error message pops up. 

 

 
 
A3) To use the LG IDE Plugin in Mac OS, follows the following steps. 
 
  1. Move to [opt\LG_Smart_TV_SDK\Resources > Libraries\jarformac] folder. 
  2. Copy org.eclipse.wst.server.preview.adapter_1.1.0.v20090311b.jar 
  3. Paste org.eclipse.wst.server.preview.adapter_1.1.0.v20090311b.jar into the [plugin] folder in Eclipse. 

 
  For details, refer to Installing the LG IDE Plugin. 

 
 
Q4) When installing the new LG Smart TV SDK version, “Instance Management Error” window appears. 

 
A4) If the previous version of LG Smart TV SDK is not uninstalled or the previous installation directory of LG Smart 
TV SDK is deleted manually, the following popup appears during installing the new version of LG Smart TV SDK. 
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Follow the next step to solve the problem. 
 
Case 1> If the previous version of LG Smart TV SDK is not uninstalled, click [OK] button in popup window. Then, the 

previous LG Smart TV SDK is automatically uninstalled. 
 
Case 2> If the previous installation directory of LG Smart TV SDK is manually deleted, the previous version of LG 

Smart TV SDK cannot be automatically uninstalled and error message pops up as below. 
 

.  
 
Then, click [OK] to close the installer. And delete the following hidden file manually. 

For Windows, C:\Program Files\Zero G Registry\.com.zerog.registry.xml 

For Linux, $HOME\.com.zerog.registry.xml 

For Mac, \library\preferences\.com.zerog.registry.xml 

 
 


